Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

-1074360278 Unknown GIGE Vision error with Basler a2A1920-51gcPRO

The same "unknown error" as described in this post is showing up on my system. I am using a Basler a2A1920-51gcPRO GiGE camera with LabVIEW 2019 SP1, with Vision 2019 SP1 also.

 

I am able to use the camera in Pylon, the software provided by Basler. When I open MAX, I can see the camera, browse the attributes, but I get an error BFF6902A (same error as above but hex code) when I try to acquire a frame.

In LabVIEW, I can open an IMAQdx session with the camera but the error happens at "IMAQdx Start Acquisition.vi".

 

I have exported the camera attributes from Pylon when I can acquire frames, and made sure they are set the same in MAX, but I still get the same error.

 

I am running out of ideas at the moment. Thanks in advance for any help.

0 Kudos
Message 1 of 5
(497 Views)

Just out of curiosity, do you happen to have the Compression Beyond feature enabled? This is a proprietary Basler feature and not part of the GigE spec, so you may see some strange behavior if you try to acquire data in IMAQdx or other third party software with that enabled.

 

I'll keep thinking about alternative things that could be going wrong, but that's my best guess for what could be happening for now.

Message 2 of 5
(468 Views)

As a side note, I wanted to mention that this -1074360278 "Unknown GigE Vision error" is typically returned when there is an issue interacting with the device that has to do with the GigE standard. Since these issues are very low level and there's often not a workaround a user could try, they're best discussed between the NI Vision Acquisition Software team and the camera vendor team with respect to how the device uses GigE Vision. Just because the user in the other post also saw this error, doesn't mean it's related at all since there are many, many different expectations in IMAQdx software related to the GigE Vision specification. Unfortunately in these situations it's best to open a support ticket to do some more in depth debugging to understand which specific situation is triggering this error. It's hard to speculate because the error is so generic, but with some help from the technical support team you could get more specific details about the situation.

 

Otherwise, we have to just guess about what could be happening, which is what I tried to do above. If that's not correct, I think reaching out to NI support will be your quickest path to resolution.

0 Kudos
Message 3 of 5
(465 Views)

Kensign, thanks a lot for your help. I check the "compression beyond" feature but it was disabled so unfortunately that wasn't it. I will follow your suggestion and contact NI support to see if they can help me directly.

0 Kudos
Message 4 of 5
(436 Views)

Ah, too bad it wasn't that simple. I have given a heads up to our technical support team about this issue. We have great technical contacts in Basler R&D, so hopefully we should be able to get it straightened out. I would expect that the new ace 2 PRO cameras should work out of the box with IMAQdx.

0 Kudos
Message 5 of 5
(408 Views)