Lookout

cancel
Showing results for 
Search instead for 
Did you mean: 

Setup to communicate using Logos to Fieldpoint from PC

I'm having a problem communicating with a cFP-2120 RT application using logos and datasocket.  I've read and tried to follow the instructions in the documents:
Developing a LabVIEW Real-Time Application for Fieldpoint
What are the different communication techniques using logos and fieldpoint
Deploying and launching a Real-Time Application
How to Allow Remote systems to create and write to Datasocket Items
Introduction to using Datasocket commands to communicate with Fieldpoint Ethernet Network Modules
Using Datasocket in LabVIEW Real-Time
 
But I still can't seem to get it to work.  I feel like I'm missing one piece of the puzzle.  Do you know of a comprehensive starting guide for this communication - PC running LV 7.1, ethernet connected cFP-2120 running a realtime app.  Datasocket commands in the PC .vi to read/write to logos items; Publish.vi's in the RT .vi ... Items show up in Max...I don't know.  I want to avoid DSC if possible (I thought that I don't need that).  Any suggestions for starting out with this?  I feel like I've done it all but if anyone has some suggestions I will try them to make sure.
 
Thanks!
0 Kudos
Message 1 of 11
(5,429 Views)
Besides the controller 2120, what kind of module are you using? such as cFP-AI-100, CTR or PWM.
First, we need to make sure the URL is correct. For example, if you use AI-100 on slot 1, read channel 0, ip10.0.0.1, the URL should be lookout:\\10.0.0.1\FP\1AI\00
 
Any error message?
 
 
Ryan Shi
National Instruments
0 Kudos
Message 2 of 11
(5,418 Views)
I believe you can get better support if you aslo post this question in FP forum.
Ryan Shi
National Instruments
0 Kudos
Message 3 of 11
(5,417 Views)

Thanks for the response.  First question - the format of the URL - is it backslashes as you have written and as is shown in here, or forward slashes as is found in the Knowledgebase document here and consistent with normal URLs?  I'm using Logos and not Lookout but from my understanding the URL is the same, just replace "lookout" with "logos". 

Thanks

0 Kudos
Message 4 of 11
(5,400 Views)
Hi again Ryan,
 
I tried your test and found I have no problem communicating with the channels on my cFP's modules (by the way I used the forward slashes in the URL).  But then when it comes to communicating with my RT application that's where I'm still having a problem.  I've attached a very simple version of the pair of .vi's that I am trying to get to work.  One is for the host (logos test.vi) and the other is for the cFP (RT SerialModule logos test.vi).  As-is, it's not working.  I embed the application on the cFP, I reboot it so it runs, I start the host PC's vi, and it doesn't do anything.  Also I don't see any new created items in Max under Data Neighborhood.  Any ideas from here?
0 Kudos
Message 5 of 11
(5,398 Views)
Hope you don't mind my intrusion. I noticed that you are creating Read-Only Items. You can't write anything to such items. You should be creating read/write items. This could be the main problem.

Secondly, you will want to output the errors from all the Publish Data functions -- either chain them all together and wire it to a final indicator, or even just create indicators for each one of them for now so you can tell what errors are occuring where.

Also, you should check in MAX if you are able to both -- read and write to these items (once you create them as read/write items).

Hope this helps.

-Khalid
Message 6 of 11
(5,386 Views)
Please ignore my last post about not creating read-only items. I wasn't thinking straight. The read-only attribute applies only to the subscribers. The publisher can (and should) be able to create and apply a value to read-only items.

-Khalid
0 Kudos
Message 7 of 11
(5,378 Views)

I tried a suggestion from the fieldpoint board to try the logos writer/reader found here.  This is the results, in case anyone of this board has any ideas too.

********
Thanks for the response.  I tried the program and it works!  That's the good news.  The bad news is that when I modified it to add a data going the opposite way (from the reader to the writer) I couldn't get that part to work.  The modified versions are attached.  I made a few notes while I did this exercise that I'll share here in case they might be important.

1. When I build the .exe / .dll file from the LogosWriterRT.vi, I am told about the file "C:\Program Files\National Instruments\LabVIEW 7.1\vi.lib\system\Glogos.dll" that "Target OS has its own version of this DLL."

2. I don't see any items created in Max in Data Neighborhood, during/after I run either the original files you told me about or my modified ones, before during and after I Refreshed and closed/reopend Max.

3. In Max, when I click under the Data Neighborhood which is under Remote Systems-cFP 2120-Data Neighborhood (i.e., not the same Data Neighborhood as I mention in #2) I get the message, "Could not load item names from the remote system.  An unknown internal condition has occured.  Possible cause: unrecoverable operating system error."

Any suggestions?

Thanks again.

0 Kudos
Message 8 of 11
(5,365 Views)
Hey Khalid,
 
I think you were right in your post about the Read-only items after all.  I couldn't get this to work no matter what I did, then I saw this example, where the author used Create Read/Write Item instead of Create Read Only item, and when I tested it, it worked fine on my machine!  Then I changed mine to be the same - all the items are now Create Read/Write Item.  And it works!  See attachment, the only change to that in my previous post is this.
 
I agree, from the Publish.vi help and from functionality, it shouldn't be like this.  So what the heck is the purpose of the Create Read-only Item then???  Anyone?
 
Also, I still don't see any item created in MAX even now that it's working.  When I click under the Data Neighborhood which is under Remote Systems-cFP 2120-Data Neighborhood I get the message, "Could not load item names from the remote system.  An unknown internal condition has occured.  Possible cause: unrecoverable operating system error."  Could this be a reason?
 
(Oh yeah, and in a question to Ryan above I asked about the direction of the slashes in the URL - Once I made the change described above I tried both directions (forward slash and backslash) and found it works both ways.)

Message Edited by Hosehead on 08-31-2006 02:38 PM

0 Kudos
Message 9 of 11
(5,223 Views)
I had to use read-write items too. Allow me to borrow your statement, since you've put it so nicely: "So what the heck is the purpose of the Create Read-only Item then???"

I have emailed NI about this. Let's see what they say.

You should be able to see the items in MAX. I can. Here's how I go about doing this: I right-click on the cFP Controller under Data neighbourhood, select Create new Item, and then LabVIEW Item to see my published items.

Regards,

-Khalid
0 Kudos
Message 10 of 11
(5,217 Views)