Showing results for 
Search instead for 
Did you mean: 

NIHypertrend in report occuring as a random problem

I had this problem again with the customer where the reports are not created properly almost every second time
The top bitmap(graph1.bmp)  is a part of the correct report and below is the bitmap (graph1.bmp) when the apparatus did the next run.
New folders are created for every machine run and report html files are copied to that folder.
There is no rule when is going to shrink graphics.The bitmap in report folder is the same physical size XY as the good one
but with shrinked visible graph area as you can see on the picture.
NIHyperTrend1.properties.CaptionColor= 0x000000;
NIHyperTrend1.properties.IsPlotting= Excel_row>12 or Sequencer_1s;
NIHyperTrend1.properties.Refresh= Sequencer_report.State=2;
NIHyperTrend1.properties.ExtendedProperties= true;
NIHyperTrend1.pollRate= 0:01;
NIHyperTrend1.properties.ActiveGroup.TrendWidth= nif(ETM3=00:00,00:05:00.000,nif
NIHyperTrend1.properties.ActiveGroup.GraphBackgroundColor= nif((Sequencer_report
                .State>=1 and Sequencer_report.State<11),0xFFFFFF,0x000000);
NIHyperTrend1.properties.ActiveGroup.GridMajorColor= nif((Sequencer_report.State
                >=1 and Sequencer_report.State<11),0xE0E0E0,0x003200);
NIHyperTrend1.properties.ActiveGroup.GridMinorColor= nif((Sequencer_report.State
                >=1 and Sequencer_report.State<11),0xE0E0E0,0x002000);
Sequencer_report= new Sequencer (11, "Preparing", 00:00:02, 0x1,
                "Create Output Directory", 00:00:05, 0x2,
                "Copy Synthesis File", 00:00:01, 0x4, "Copy Synthesis File",
                00:00:01, 0x8, "Create Pressure Graph", 00:00:01.5, 0x10,
                "Create Temperature Graph", 00:00:01.5, 0x20,
                "Create  Detector Graph", 00:00:01.5, 0x40,
                "Create Report HTM File", 00:00:02, 0x80, "Report Saved",
                00:00:02, 0x100, , 00:00:02, 0x200);
Sequencer_report.Goto1= (Create_Report_1s or e_302_dlaON);
Sequencer_report.Goto11= (Excel_0_1s);
(1s=one shot, dlaON = delay on timer).
The process is running on Excel spreadsheet data and Hypertrends are stopped. Just before the report creation point Hypertrend time base are kicked to process start time and started to plot. After the HTML report is created graphs are stopped.
Problem persist on random basis which is unacceptable for the customer and I cannot see what is wrong as it happens randomly but very often.
That was question answer while ago:
In which way do you add the hypertrend to report?
I connect hypertrend.graphic to report.display. When the report is created, there will be an html file and a bmp file. The bmp file is the hypertrend. So, in the html report, there are no more hypertrend objects, but only some pics. If the pic shrinks to a small one in report, you can check the bmp file if it is still of the right size.
And also you can check if the bmp is black. If it is, the hypertrend in report should be black.

Message Edited by Ryan.S on 09-21-2006 09:45 PM

Ryan Shi
Applications Engineer
National Instruments
0 Kudos
Message 1 of 8

What version of Lookout are you using?

Can you post a simplified process file that reproduces the behavior you are seeing? That would greatly help us in figuring out what may be going wrong.
Doug M
Applications Engineer
National Instruments
For those unfamiliar with NBC's The Office, my icon is NOT a picture of me 🙂
0 Kudos
Message 2 of 8
Thanks Doug,
I'll try to put together some example during this week, I have to include the sequence which creates report, creates folder, copies files, etc to recreate the part of this process.
The other unsolved problem what I have is the SQL server which is used by lookout, slows down the AMD sempron 3000+ based laptop to the point of uselesness, even if no process file has been loaded yet.
I tried to archive/delete databases and nothing, but only what helps is to stop sql server service while lookout is running, at that point the C++ Runtime error warning window appears.
There is no such a problem with that on Intel centrino based laptop,... strange?
0 Kudos
Message 3 of 8
Forgot to include:
Lookut version 6.02 (build 1)
0 Kudos
Message 4 of 8
Have you ever tried to restart the sql server service?
You have tried to delete the database and create a new one. right?
Ryan Shi
National Instruments
0 Kudos
Message 5 of 8
Yes, I tried to restart SQL service again and at this point uses 95-100% processor ressources as before.
Database ha been archived and deleted using the Measurement and automation explorer.
In order to create/recreate database or a single connection between Lookout and the database, the SQL server has to be back on. 
If I stop SQL service, the Nicitdl5.exe process is terminated automaticaly.
I don't need neccessary the SQL server to run the process as long I don't have to enter the database connections tree. 
0 Kudos
Message 6 of 8
If you detach the database, what will happen?
Ryan Shi
National Instruments
0 Kudos
Message 7 of 8
I did detached the database, it increases memory usage by sqlserver from 49500k to 105000k., processor usage jumping around 83% - 98% -100%
As soon the Lookout is started the database appears again on the tree view.
Conclusion, it does actually nothing good as it doubles the ammount of memory usage.
I still believe this is a hardware problem as it works well on centrino machine.
0 Kudos
Message 8 of 8