Lookout

cancel
Showing results for 
Search instead for 
Did you mean: 

Lookout OPC server and NI-DAQmx

Hi!

I have a problem accessing a SCXI-rack from Lookout 5.1 It has worked but something happened when I upgraded the drivers.

I can’t get any readings from the Global Virtual Channels created in MAX. They work there but I only get “???” in every column in Server Explorer. When I try to validate a channel there I get a reply that “On or more arguments are invalid”

I use Lookout 5.1 running on a Windows XP Pro SP3 Dell WS390
My hardware is a FieldPoint system; the old grey one and I also have two SCXI-racks witch each has a SCXI-1600 as acquisition front end. The first is Ethernet connected; the second is USB through a small USB-HUB.

My problem is that I upgraded the FieldPoint driver software from unknown version (probably 6.0.5) to the latest 6.0.7 (why I now wonder? after working all weekend with this). Then suddenly my SCXI-rack stopped working. The OPC (unspecified which) sometimes hang and it was a small hope that it might help.

Facts: I have two OPC servers running, OPC FieldPoint which takes care of the FieldPoint system, it works fine and has done so all the time.
I also use the Lookout OPCserver to connect to my Global Virtual Channels, 128 of them.

It is running in two separate processes, called MAIN and CV_MON. MAIN takes care of the FieldPoint and CV_MON measure the voltages in the Fuelcell that we control.

When I run Server Explorer the channels show up but present no values, sometimes it shows up a “bad value”, otherwise nothing.

The channels work, I can use them in MAX and in NI Signal Express. I have tried to make just one channel in MAX but it doesn't’t help, it is also stuck with “???” when viewed from Server Explorer.

How shall I configure the OPCclient to access the Lookout OPCserver in Lookout? I have seen different settings on the forum/knowledgebase. One said ”use default settings” which is OPC2, Local Server and Hierarchical, Mr. Ryan Shi wrote on another thread that you should use In-Process Server and Flat, which is preferable/works?

The servers are registered in Server Explorer when taken “Properties”.

Do I need old legacy NI-DAQ 7.4.4 to make this work, Lookout 5.1 should work with DAQmx? When I installed the NI-DAQ 7.4.4 I got another OPC server stated “DAQOpc” in Server explorer, I don’t need that, I connect to the Lookout OPC Server?

I have also applied all the recommendation from OPC Foundation regarding DCOM settings as stated in a thread on the forum. I have also given some ten programs and port access through the Windows Firewall. I now have NI-DAQmx 9.2.1 installed.

I have also tried the new compiled version of Lookout OPC server (lkopc.exe) presented in another thread on the forum and also the new version of the OPC-client in lookout (opclinet.cbx), no difference.

I tried yesterday to uninstall all NI-software, no manual registry removal, didn’t help. I also tried with a fresh DAQmx window in MAX; the only thing that happened was that I lost all 128 channels; the export/import didn’t work..

Any suggestions?

Best Regards
Mikael Ohlsson

0 Kudos
Message 1 of 2
(5,174 Views)

Since the Server Explorer doesn't work, the problem is not in Lookout or OPClient Object. The problem is in the OPC Server.

Actually the OPC Server for the DAQ is installed by the DAQ driver, so I guess that something is modified after you upgraded the FP driver.

 

What's the previous version of the DAQmx driver? If it's not 9.2.1, could you try to install the previous DAQmx driver on an clean machine. And create simulated device in MAX, and create channels on simulated device. Try to use the Server Explorer to read the data from simulated device. As it did work before, a clean machine with the same version of driver should work.

 

I guess something related to DAQ OPC in the driver or Logos is broken. I will do some test here with the latest DAQmx driver. I will do it from a clean machine.

Ryan Shi
National Instruments
0 Kudos
Message 2 of 2
(5,135 Views)