Lookout

cancel
Showing results for 
Search instead for 
Did you mean: 

Active Alarm in Status Bar Problem

Hello,
I am using LookOut 6.0. At the bottom right, the Alarm Counter in the Status Bar indicates that there are active alarms. But when you open the Alarms Window there are no alarms there. Any ideas why?


Message Edited by Squire66 on 11-25-2005 11:12 AM

0 Kudos
Message 1 of 13
(4,241 Views)

Hi Squire66,

Go to Alarms ->Filter Options... and this brings up the 'New Alarm Filters' pop-up window where you can configure Lookout to show only alarms or only events or both alarms and events. Hope this helps!

Regards,
Prashanth

0 Kudos
Message 2 of 13
(4,214 Views)
That doesn't help. It is my understanding that the status bar and the alarm window should have the same number of alarms. So if the Status bar says 4 alarms, and I open the alarm window I should see four lines of alarms. However, in my case, the Status bar says 4 alarms, and I open the alarm window and there are no alarms, just a blank screen.

0 Kudos
Message 3 of 13
(4,208 Views)

Hi Squire66,

Can you check to see if all of your column headers [Such as Time, Process, Area...] are visible? Can you see any alarms in the alarms window? Are you seeing this behavior consistently in Lookout? Is there a specific set of steps to reproduce this issue with a new process?

Regards,
Prashanth

0 Kudos
Message 4 of 13
(4,196 Views)

After I upgraded from Lookout V5.1 to V6.X I have noticed that the "alarm filter" doesn't work as expected. Even tho I have "alarms only" selected, the alarm window still allows Events to populate the alarm window.

The workaround I have found is that i have to open the Alarm Filter, select Alarms and Events radio button, click OK. Reopen the Alarm filter and select Alarms Only, click OK.

This works until I restart Lookout, when I have to go thru this process all over again.

 

(this is not a permissions problem, as I have this issue when loged into the computer as the administrator, and loged into Lookout as the administrator)

(again, didn't have this problem with V5.1)

 

Anyone else seeing this behaviour?

 

Richa

0 Kudos
Message 5 of 13
(3,678 Views)

Richa,

 

It is a known problem in Lookout client software. The filter in client may not work.

 

But the lookout server software doesn't have this problem. The filter works correctly.

Ryan Shi
National Instruments
Message 6 of 13
(3,652 Views)

This "alarm filter not working in the clients" is a problem for me. My operators are getting hundreds of "alarms" (each time they press a button, or twist a pot). They even get 'alarms' when an operator down the line in a different department turns a pot. (we've got unlimited IO and unlimited Clients, all talking to a single Lookout Server used for SCADA.)

 

This worked correctly with V5.1 and prior. We've always used the alarm window to diaplay alarms only.

 

Is there a workaround for this? If no one has a workaround, can I get a copy of zero IO, zero Clients runtime server and install that for clients?? Maybe that would solve this for me.

 

Rich Anderson

0 Kudos
Message 7 of 13
(3,569 Views)

It is a known issue only in Lookout 6.x. I suggest you to use the ActiveX control to display the alarm/event on lookout client. It is able to filter alarm or event. You can put this control on a specific panel and use that panel as the Alarm Window.

 

Complete the following steps to use the ActiveX control.

1.Add the ActiveX object called NI AlarmEvent Browser to the Client Process. Object->Create->ActiveX tab->NI AlarmEvent Browser.

2.On the Properties window for the ActiveX object, click on the Property Pages button.

3.Set the PopupMenu property to True and then set the Active property to True.

4.Exit and close out of the various property windows, saving the changes.

5.Drag the new ActiveX object onto the panel and size appropriately.

6.Go to Run Mode.

7.Right-click on the Alarm and Event Viewer and choose to Select Processes...

8.Select the server process you wish to monitor and click OK.

9.You should now see any active alarms and events. Right-click on the Alarm and Event Viewer again to set the Filter Options and acknowledge alarms.

Ryan Shi
National Instruments
0 Kudos
Message 8 of 13
(3,560 Views)

I did what you suggested about the ActiveX Alarm. And I see what it does. however, on the status line, right side, it still generates an alarm count for every event. (operators getting this number in the thousands every day).

 

I also tryed this to see if it would help:

 

(Menu: Alarms: Filter Options...: [checked "Object Name" and typed in "none" (no object called none, hoping it would not report any)]  ["Show" selected radio "Alarms Only"] (didn't help.)

 

(Menu: Alarms: Select Processes...: [only item on right side ("Selected Processes") is my server process. (I removed the default 'local' process)] (didn't help, and the 'local' process kept putting itself back in the list.)

 

I even tryed connecting an expression [pulse(on,00:00:10,00:00:01)]) to $Alarm.clearEvent in an effort to get these to stop appearing on the Status Bar.

 

NI: PLEASE get this corrected.

 

rich

0 Kudos
Message 9 of 13
(3,551 Views)

To use the $Alarm.clearEvent is a workaround. It will clear all the events in the Alarm Windows as well as the status bar.

 

 

Ryan Shi
National Instruments
0 Kudos
Message 10 of 13
(3,536 Views)