Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

libnipalu.so failed to initialize - OPENSUSE 42.2 NI-VISA 17.0

Hi,

 

I've been trying to setup NIVISA17.0 in opensuse 42.2 and  i finish as following step 

zcat /boot/symvers-<version>.gz > Module.symvers
make cloneconfig
make modules_prepare
updateNIDrivers

 

and i setup Smiley Tongueip install nivisa

import visa

rm = visa.ResourceManager()

 but it's giving me the following error:

 

libnipalu.so failed to initialize
Perhaps you need to run updateNIDrivers
Aborted (core dumped)   
 

 when i 

The same happens even after I run updateNIDrivers

 

and here is the output from rpm -qa|grep "^ni"

ni-apal-errors-17.0.0.49152-0+f0.noarch
ni-pxirm-17.0.0.49155-0+f3.x86_64
nissli-32bit-17.0.0-f0.x86_64
ni-pal-17.0.0.49152-0+f0.x86_64
niiotracei-17.0.0-f0.x86_64
ni-mdbg-nikalmod-17.0.0.49152-0+f0.x86_64
nitargetcfgi-3.0.0-f1.x86_64
nispylogsupp-32bit-17.0.0-f0.x86_64
ni-pxipf-errors-17.0.0.49152-0+f0.noarch
ni-pal-32bit-17.0.0.49152-0+f0.x86_64
ni-visa-sysapi-17.0.0.49152-0+f0.x86_64
nivisaserver-17.0.0-f0.i386
nirocoerri-17.0.0-f1.i386
ni-orb-nikalmod-17.0.0.49152-0+f0.x86_64
ni-mdbg-17.0.0.49152-0+f0.x86_64
nipalki-17.0.0.49152-0+f0.noarch
nisvcloc-17.0.0-1.noarch
nipxipfi-17.0.0.49155-0+f3.noarch
ni-mxdf-32bit-17.0.0.49152-0+f0.x86_64
ni-mdbg-errors-17.0.0.49152-0+f0.noarch
ni-mxdf-nikalmod-17.0.0.49152-0+f0.x86_64
nimdnsresponder-17.0.0-f0.i386
nisyscfgi-17.0.0-f0.x86_64
ni-pxirm-resources-17.0.0.49155-0+f3.noarch
nivisa-config-17.0.0-f0.i386
nipxipfki-17.0.0.49155-0+f3.noarch
ni-kal-17.0.0.49152-0+f0.noarch
ni-pal-nikalmod-17.0.0.49152-0+f0.x86_64
ni-orb-32bit-17.0.0.49152-0+f0.x86_64
ni-mdbg-32bit-17.0.0.49152-0+f0.x86_64
nivisa-32bit-17.0.0-f0.x86_64
nidimi-32bit-17.0.0-f0.x86_64
ni-orb-errors-17.0.0.49152-0+f0.noarch
ni-orb-17.0.0.49152-0+f0.x86_64
nisslcerts-17.0.0-3.0.noarch
nivisak-17.0.0-f0.x86_64
nispylogsupp-17.0.0-f0.x86_64
nisyscfgi-32bit-17.0.0-f0.x86_64
nidimki-17.0.0-f0.x86_64
nidimi-17.0.0-f0.x86_64
nivisa-devel-17.0.0-f0.i386
nissli-17.0.0-f0.x86_64
ni-pxirm-nikalmod-17.0.0.49155-0+f3.x86_64
nivisa-17.0.0-f0.x86_64
ni-visa-sysapi-32bit-17.0.0.49152-0+f0.x86_64
ni-mxdf-errors-17.0.0.49152-0+f0.noarch
nicurli-17.0.0-f0.x86_64
nispyi-2.8.1-f0.i386
nicurli-32bit-17.0.0-f0.x86_64
ni-pal-errors-17.0.0.49152-0+f0.noarch
ni-mxdf-17.0.0.49152-0+f0.x86_64

 

and i found some setup log file in TMP in attachment

 

Thanks for your time!

 

 

0 Kudos
Message 1 of 4
(445 Views)
3 REPLIES

Re: libnipalu.so failed to initialize - OPENSUSE 42.2 NI-VISA 17.0

What are the results of "lsmod | grep ni" and "modprobe nikal"?

0 Kudos
Message 2 of 4
(424 Views)

Re: libnipalu.so failed to initialize - OPENSUSE 42.2 NI-VISA 17.0

Thanks for you responsed.

The return message as following:

linux-2hkh:~ # lsmod |grep ni
ghash_clmulni_intel 16384 0
cryptd 20480 1 ghash_clmulni_intel
linux-2hkh:~ # modprobe nikal
linux-2hkh:~ #

 

and i found

linux-2hkh:~ # cd /usr/src/
linux-2hkh:/usr/src # ls -l
total 4
lrwxrwxrwx 1 root root 19 Sep 26 02:30 linux -> linux-4.4.104-18.44
drwxr-xr-x 1 root root 598 Sep 26 02:33 linux-4.4.104-18.44
drwxr-xr-x 1 root root 12 Sep 26 02:30 linux-4.4.104-18.44-obj
drwxr-xr-x 1 root root 12 Sep 26 02:30 linux-obj
drwxr-xr-x 1 root root 132 Sep 26 02:37 ni-pxipf
drwxr-xr-x 1 root root 70 Sep 25 05:24 packages
linux-2hkh:/usr/src # uname -r
4.4.104-18.44-default

the kernel version is 4.4.104-18.44-default but in /usr/scr/  folder doesn't have the same name ,if this is the issue?

0 Kudos
Message 3 of 4
(420 Views)

Re: libnipalu.so failed to initialize - OPENSUSE 42.2 NI-VISA 17.0

This is a known issue.  Please see the resolution at http://digital.ni.com/public.nsf/allkb/AB92119277C041FE86257FAB005446AC?OpenDocument.

 

Alternatively, you could try installing the 18.2 version of NI-VISA.  This will require you to ./UNINSTALL the existing driver distribution.  Then, follow the general directions at http://www.ni.com/product-documentation/54754/en/, installing rpm_OpenSUSE422.rpm from http://www.ni.com/download/ni-linux-device-drivers-2018/7664/en/ and doing "zypper install ni-visa".  It works fine for me on 42.2, and you don't have to do any of the other preliminary steps, either.

 

 

0 Kudos
Message 4 of 4
(407 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.