Linux Users

This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.

installing NI-488.2 on opensuse

I have a pci-gpib card that I'm trying to get working on a computer running opensuse 11.4.  I've tried installing the 2.5.1b1 package and the 2.5.4b1 (64-bit) package with no luck on either count.  I followed the steps at the end of the readme file concerning prepping of the kernel source but when I run the install script I get:

******************************** ERROR ****************************************

* Kernel source in /lib/modules/ does not appear to be

* configured for the kernel.

* Configuration of kernel source is required to continue installation.        *

* Refer to the README file for the product you are installing for information *

* about configuring your kernel source.                                       *

******************************** ERROR ****************************************

What do I do in the "/lib/modules..." directory?  Is there a better set of instructions somewhere?  Does ni-488.2 even work with opensuse 11.4?  The compatibility chart suggests it may not. 



0 Kudos
Message 1 of 3

installing NI-488.2 on opensuse

Hi! I have the same error. I tried to install NI-488.2 version 2.5.1f0 for Linux/x86 32-bit on openSUSE 11.3 (kernel I followed the instructions listed at the end of the README.txt file, but that didn't solve the issue.

Lookig at the installation script, the error is raised when it checks for the $headersDir/include/asm directory ($headersDIR is /lib/modules/, which is just a link to /usr/src/linux- and then for the $headersDir/include/asm/asm-offsets.h file.

I don't have either of those in my system. However, there's a $headersDir/include/asm-generic directory and a $headersDir/arch/x86/include/asm/asm-offsets.h file.

Is there anyone here that can tell me how to install Ni-488? Or at least point me in the right direction? I couldn't find any useful info in this forum, or even googling around.

Thanks in advance!


0 Kudos
Message 2 of 3

installing NI-488.2 on opensuse

NI-488.2 depends on NI-KAL. KAL that supports suse 11.4 isn't yet released. see this thread:

KAL that supports 11.3 is released, that's KAL 2.1:

However, that error seems to be something else. Which instructions did you guys follow from the readme? this one?

"On openSUSE complete the following steps:

1. Ensure you have installed kernel-source and kernel-syms packages

   corresponding to the version of the currently running kernel. The version of

   the currently running kernel can be determined by issuing the command

   "uname -r".

2. Change the directory to the /usr/src/linux-<version> directory, where

   <version> corresponds to the currently running kernel version.

3. Run "zcat /boot/symvers-<version>.gz > Module.symvers" as root to prepare

   modversion support.

4. Run "make cloneconfig" as root to configure the sources for the currently

   running kernel.

5. Run "make modules_prepare" as root to prepare the headers for compilation.

6. Run the NI-KAL INSTALL script."

AFAIK, I've only gotten that error message when I forgot to prepare my kernel with that instruction.

0 Kudos
Message 3 of 3
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.