Linux Users

cancel
Showing results for 
Search instead for 
Did you mean: 

install successfull of NI-VISA on Redhat, but no VISA utilities

Thank you for helping me.

here are the logs :

Installing NI-VISA for Linux version 5.4.1f0...

Pre Installation .

Post Installation .

Skipping labview-2012-rte-12.0.1-4.i386.rpm installation, same or newer already installed.

Pre Installation .

Warning: nikali pre uninstallation failed! /tmp/nikaliPreUninstall.log follows:

/mnt/iso/INSTALL: line 2056: Uninstalling: command not found

..remove: no existing module: nipalk

................................

Preparing...                ########################################### [100%]

   1:nikali                 ########################################### [  4%]

   2:nipalki                ########################################### [  8%]

   3:nirpci                 ########################################### [ 12%]

   4:nivisak                ########################################### [ 15%]

   5:nisvcloc               ########################################### [ 19%]

   6:nispyi                 ########################################### [ 23%]

   7:nipalerri              ########################################### [ 27%]

   8:nipali                 ########################################### [ 31%]

   9:niorbki                ########################################### [ 35%]

  10:niorbi                 ########################################### [ 38%]

  11:nidimki                ########################################### [ 42%]

  12:nidimi                 ########################################### [ 46%]

  13:nimdbgki               ########################################### [ 50%]

  14:nimdbgi                ########################################### [ 54%]

  15:nimxdfki               ########################################### [ 58%]

  16:nimxdfi                ########################################### [ 62%]

  17:nipxipfki              ########################################### [ 65%]

  18:nimdnsresponder        ########################################### [ 69%]

  19:nivisa                 ########################################### [ 73%]

  20:niapalerri             ########################################### [ 77%]

  21:nipxipfi               ########################################### [ 81%]

  22:niiotracei             ########################################### [ 85%]

  23:nipxirmi               ########################################### [ 88%]

  24:nivisa-config          ########################################### [ 92%]

  25:nivisa-devel           ########################################### [ 96%]

  26:nivisaserver           ########################################### [100%]

Post Installation .

Warning: nikali post installation failed! /tmp/nikaliPostInstall.log follows:

ERROR: failed to build NiViPxiK.ko

NiViPxiK.ko failed to update.

Update of National Instruments drivers failed.

..................................

Updating modversions database to include newly installed drivers...

FOR PATENTS COVERING NATIONAL INSTRUMENTS PRODUCTS, REFER TO

THE PATENTS.txt FILE ON /mnt/iso AND/OR

www.ni.com/patents

2 errors (maybe linked?). But visaconf command is working now!

0 Kudos
Message 11 of 16
(1,047 Views)

Awesome! This is more of what I would have expected to see, the only problem now are those errors they shouldn't happen, but thankfully in this case we have some logs. Could you get us the contents of those logs? (/tmp/nikaliPostInstall.log and /tmp/nikaliPreUninstall.log) I would like to see what those are to get your system back into a stable state.

Right now some functionality of NI-VISA may not be working properly, but it might be originating from software pieces that could affect other NI software on the system so we'll want to iron the issues out as well.

Chris T.
0 Kudos
Message 12 of 16
(1,047 Views)

Hi,

thank you again for your precise and personnalised help.

So, I've uninstalled everything, and tried to reinstall from scratch :

NI-488.2 2.9.1, and then VISA 5.4.1.

In the kernel options I specified the maximum memory :

mem=4096M

While installing NI-VISA I had the following errors :


Installing NI-VISA for Linux version 5.4.1f0...

Pre Installation .

Post Installation .

Skipping labview-2012-rte-12.0.1-4.i386.rpm installation, same or newer already installed.

Pre Installation .Makefile:54: ../nikal/Makefile.in: No such file or directory

make: *** No rule to make target `../nikal/Makefile.in'.  Stop.

Warning: nikali pre uninstallation failed! /tmp/nikaliPreUninstall.log follows:

INSTALL: line 2056: /mnt/iso: is a directory

..remove: no existing module: nipalk

Now I have the following packages :

nispyi-2.8.1-f0

nimdbgi-3.0.0-f0

niiotracei-3.1.0-f0

nirpci-4.3.0-f0

nidimki-3.0.0-f0

nivisa-5.4.1-f0

ni4882ki-2.9.1-f0

ni4882i-2.9.1-f0

nivisak-5.4.1-f0

nipali-2.9.1-f0

nidimi-3.0.0-f0

nimxdfi-3.0.0-f0

niapalerri-2.3.1-f0

nivisa-config-5.4.1-f0

nikali-2.5.0-f0

nisvcloc-13.5.0-1

niorbki-3.0.0-f0

nimdbgki-3.0.0-f0

nipxipfki-2.1.0-f0

nipxipfi-2.1.0-f0

nivisa-devel-5.4.0-f0

nipalki-2.9.1-f0

niorbi-3.0.0-f0

nimdnsresponder-2.2.0-f0

nivisaserver-5.4.0-f0

nipalerri-2.9.1-f0

nimxdfki-3.0.0-f0

nipxirmi-2.8.0-f0

I've attached the NISystemReport file.

Everything is working fine except that my GPIB-USB-HS dongle is not well detected in VISA utilities... (see attached picture).

Download All
0 Kudos
Message 13 of 16
(1,047 Views)

in fact I've added memmap=60G$0x100000000 to the grub.conf file.

0 Kudos
Message 14 of 16
(1,047 Views)

Thank you for the NISystemReport!

From the output of the INSTALL and the NISystemReport we didn't see anything related to the warning that would have caused the issues you are seeing.

However, looking through the NISystemReport we noticed that something might be going on with the usb side of things on your OS since some of the related commands were returning errors when NISystemReport tried to call them.

Some steps we want you to try out and give us the output.

1) ls -l /proc/bus

2) lsusb -t

In the first step you should see /proc/bus/usb, if you don't then it is likely that lsusb -t will also fail. If both do, please try running

 mount -t usbfs none /proc/bus/usb 

and try running the two commands above again.

As reference and for more information, the mount command was found here https://www.kernel.org/doc/Documentation/usb/proc_usb_info.txt

Chris T.
Message 15 of 16
(1,047 Views)

Hi,

here are the answer to :

ls -l /proc/bus

total 0

dr-xr-xr-x 2 root root 0 Mar 17 09:37 input

dr-xr-xr-x 2 root root 0 Mar 17 09:37 pccard

dr-xr-xr-x 7 root root 0 Mar 15 10:41 pci

drwxr-xr-x 4 root root 0 Mar 15 10:37 usb

/sbin/lsusb -t

Protocol spec without prior Class and Subclass spec at line 4297

Bus#  2

`-Dev#   1 Vendor 0x0000 Product 0x0000

  `-Dev#   2 Vendor 0x8087 Product 0x0024

    |-Dev#   6 Vendor 0x3923 Product 0x709b

    |-Dev#   4 Vendor 0x03f0 Product 0x0024

    `-Dev#   5 Vendor 0x03f0 Product 0x2c24

Bus#  1

`-Dev#   1 Vendor 0x0000 Product 0x0000

  `-Dev#   2 Vendor 0x8087 Product 0x0024

So it seems ok, but there still the yellow question mark on GPIB-USB-HS on NIvisaic utility...

For the /usr/sbin/lsusb = command not found in the system report, I've added a symbolic link to /sbin/lsusb like here https://bugzilla.redhat.com/show_bug.cgi?id=736739

I did the same for /usr/bin/lspci.


I tried to run updateNIDrivers :

Kernel has version.h in include/generated/uapi/: no

Kernel has reparent_to_init(): no

Number of arguments for do_munmap(): 3

Kernel has vm_mmap(): no

Kernel has vm_munmap(): no

Kernel has VM_RESERVED: yes

Kernel struct pci_dev has busn_res member: no

pte_offset function: pte_offset_kernel()

Levels in page table: 4

Kernel has remap_pfn_range: yes

Kernel has kzalloc: yes

Kernel has chained SGL support: no

USB altsetting name: cur_altsetting

Kernel has usb_get_intf(): yes

Kernel has intf_cache member in usb_host_config: yes

Kernel has ep[] members in usb_device: yes

Kernel exports usb_set_configuration(): no

Units of USB_CTRL_GET_TIMEOUT: msec

Kernel has owner member in usb_driver: no

Kernel has put_page_testzero(): yes

Kernel has mutex method: yes

Kernel has wait_for_completion_interruptible: yes

Kernel has config.h: yes

Kernel has ioctl32.h: yes

IRQ handlers have pt_regs: yes

Kernel has work_struct and delayed_work: no

Kernel supports fault method in vm_operations_struct: no

Kernel has ioremap_wc: no

Kernel has pgprot_writecombine: no

Kernel has cred.h: no

Kernel has UMH constants: no

Kernel has create_proc_read_entry: yes

Kernel has namespaced generic netlink API: no

Kernel has genlmsg_new: no

Kernel has family genlmsg_put: no

Kernel has usleep_range(): no

Kernel has RS-485 serial_core support: no

Storing configuration in Makefile.in

If the values stored are incorrect they can be changed before running make.

Installing NI-KAL:

NI-KAL successfully updated.

Updating client modules:

WARNING: could not unload module nimxdfk from memory

nipalk.ko successfully updated.

ni488k.ko successfully updated.

WARNING: could not unload module nimxdfk from memory

niorbk.ko successfully updated.

WARNING: could not unload module nipxirmk from memory

nidimk.ko successfully updated.

WARNING: could not unload module nimxdfk from memory

nimdbgk.ko successfully updated.

WARNING: could not unload module nimxdfk from memory

nimxdfk.ko successfully updated.

WARNING: could not unload module nipxirmk from memory

nipxirmk.ko successfully updated.

nipxigpk.ko successfully updated.

ni488lock.ko successfully updated.

NiViPciK.ko successfully updated.

NiViPxiK.ko successfully updated.

Rebooting is required to ensure that National Instruments drivers

have been successfully updated.

Would you like to reboot now? [yes|no]

FYI, NI-488.2 Troubleshooting Wizard successfully complete without error on GPIB-USB-HS... It is very strange that VISA cannot work properly on this device. Maybe NI-488 & VISA driver cannot operate in parallel ?

Thanks!

0 Kudos
Message 16 of 16
(1,047 Views)