Linux Users

cancel
Showing results for 
Search instead for 
Did you mean: 

insserv-compat required for NI-DAQmx 20.1 under openSUSE Leap 15.1

The NI-DAQmx 20.1 installer for openSUSE Leap 15.1 requires the "insserv" command, however not all openSUSE installations include that command. If you install openSUSE in the text-only "Server" configuration, you will need to install the insserv-compat package (e.g. zypper install -y insserv-compat) before installing NI-DAQmx. This problem may exist in other configurations as well, you'll get installer errors if it can't find insserv.

Chuck Cox
Embedded Systems Engineer
SynchroSystems
0 Kudos
Message 1 of 2
(225 Views)

Yep, that is definitely a thing.

 

My hope it that everything will migrate to systemd soon and dealing with sysv init scripts will be unnecessary.

0 Kudos
Message 2 of 2
(216 Views)