Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

failed to viRead when using VISA 18.2 on centos 7

I used the .rpm file from http://www.ni.com/download/ni-linux-device-drivers-2018/7664/en/ , which link is updated on Oct.2018. I think this is the latest driver for centos. And I have a NI9191 which has a ethernet port.

 

When I use TCPIP:: SOCKET to connect to my NI9191, I can get attributes from it, But when I use viRead() function, it failed that says "operation failed due to I/o error". And there is no other than socket resource I can use, and I used SCPI commands such as "*IDN?\n", I can viWrite() but cannot viRead(). Two reasons maybe:

 

*  NI9191 doesn't support SCPI? How can I assure this?

* The driver doesn't work, I need to install VISA 15.0 on centos?

0 Kudos
Message 1 of 2
(32 Views)
1 REPLY

Re: failed to viRead when using VISA 18.2 on centos 7

The NI-9191 is meant to be used with the NI-DAQmx drivers and not by sending VISA commands.

 

Unfortunately, CompactDAQ devices aren't compatible with the DAQmx drivers for Linux.

 

Currently, I believe it will be impossible to use the NI-9191 from a Linux system.

0 Kudos
Message 2 of 2
(6 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.