Linux Users

Highlighted

an other Umbuto 12.04 install help question :)

Hi all

i have read some of the other threds here on the forum, where i downloaded the NI-Visa.5.4.0.iso and unpacked it.

when i runned the installer, it started up but i did not install any thing, the folder is there but nothing in it, here is the how it looks

i have just started with linux so i have no clue how to fix this issue.

Br

Bre

*****************************************************************************

  NI-VISA for Linux

     version 5.4.0f0 for Linux

*****************************************************************************

National Instruments products support the following Linux distributions:

   openSUSE

   Red Hat Enterprise Linux Desktop + Workstation

   Scientific Linux

Refer to README.txt for the latest information at the time of release.

Refer to www.ni.com/linux for the most recent information about Linux

support at National Instruments.

Continue? [Yn] Y

Checking required install tools...

Checking installer tool versions...

rpm        Not found in current path

tar        1.26

Checking dependencies...

glibc      2.15

Unpacking install files to /tmp/nivisa-5.4.0f0.install...

### all the agreement stuff

NI-VISA for Linux version 5.4.0f0

is about to be installed using rpm at /usr/local/natinst

./INSTALL: line 1515: -q: command not found

Would you like to continue? [Yn] Y

Installing NI-VISA for Linux version 5.4.0f0...

Pre Installation .

Post Installation .

./INSTALL: line 419: --showrc: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

./INSTALL: line 667: -qp: command not found

Pre Installation ...................................

Post Installation ...................................

FOR PATENTS COVERING NATIONAL INSTRUMENTS PRODUCTS, REFER TO

THE PATENTS.txt FILE ON /home/CORPUSERS/23049829/test AND/OR

www.ni.com/patents

NI-VISA for Linux Installation completed successfully.

0 Kudos
Message 1 of 7
(4,059 Views)
6 REPLIES 6

Re: an other Umbuto 12.04 install help question :)

forgot to mention that i unpacked the iso in my home folder and, started the install from there.

Br

Bre

0 Kudos
Message 2 of 7
(2,251 Views)

Re: an other Umbuto 12.04 install help question :)

Hi,

Your problem is rpm Not found in current path

Ubuntu is deb package based distribution not rpm.

You should read thread about how install NI-VISA on deb based distribution.

0 Kudos
Message 3 of 7
(2,251 Views)

Re: an other Umbuto 12.04 install help question :)

thank you for the fast answer, im learning linux as we speak   gone see if i can find the thread your recomending.

0 Kudos
Message 4 of 7
(2,251 Views)

Re: an other Umbuto 12.04 install help question :)

was looking at this one,https://decibel.ni.com/content/docs/DOC-6742  but its only for 32Bit, and i have a 64Bit umbot machine

even though i used Alien to convert the RPM to DBM i got stuck due too the installer did not fint the files..

i probobly gone do an ugly version with a ptyhon server on my win machine with the instrument, and send the info back to the linux, not a fun solution :/ but i cant spend days on trying to figure out, and learn at the same time... was hoping for an easy tutorial or solution

0 Kudos
Message 5 of 7
(2,251 Views)

Re: an other Umbuto 12.04 install help question :)

More information about 64-bit.

I have installed NI-VISA on Mageia Linux 2 64-bit without problems. It is rmp distro similar to RedHat Linux.

NI-VISa configuration utility also works, but I don't discover if I can create LabView application with VISA.

I think the best way is try to install NI-VISA on 64-bit rpm based distro (RadHat, OpenSUSE and Scientific Linux are officially supported)

0 Kudos
Message 6 of 7
(2,251 Views)

Re: an other Umbuto 12.04 install help question :)

I wonder why NI doesn't manage that trivial task of providing .deb packages.

Seriously, that's really easy.

Linux Embedded / Kernel Hacker / BSP / Driver development / Systems engineering
0 Kudos
Message 7 of 7
(913 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.