Linux Users

Highlighted

VIPM-2017 package compilation for Arch Linux and Manjaro Linux, using pkgbuild. FUNCTIONAL and tested together with LabVIEW-2018-SP1

pkgbuild_vipm-2017_Arch-Linux

Create the package.xz using PKGBUILD to install "vipm-17.0.2018-1-x86_64.tar.xz - VI Package Manager (VIPM)" on Arch Linux and Manjaro Linux Distro.

Running VIPM for Linux:

VIPM for Linux must be run with admin or root level privileges. There is no way around this. If you run VIPM as a standard user, it will not work as expected and will generate errors. To do this, navigate to the installation folder at /usr/local/JKI/VIPM and execute the following: $ sudo ./vipm You will be prompted for your root password. Enter the password and VIPM will launch. If you need help with VIPM, visit our Community Forums at https://forums.jki.net

To download VIPM (eng)

Access the following link "https://vipm.jki.net/download" and select the package for Linux, you must indicate an email to access the download, after downloading the package "vipm-17.0.2018-linux. tar.gz "copy it to the root of the PKGBUILD folder. Right there open a command terminal and run "$ makepkg -sri", once the package is compiled it will ask you for the superuser key to install the package in your Arch Linux or Manjaro Linux distribution.

You can manually check the hash of the file "vipm-17.0.2018-linux.tar.gz" once downloaded from the VIPM server, it would be the following hash SHA256SUM 'e105211c39b207cae2c1c0d1fca05fe09364890b420a7e8493e1df46f53db373'. (also the PKGBUILD verifies it automatically)

Changelog (eng)

2020.04.12 ->

  • Initial compilation of the package for archlinux, to work properly you must run from console "$ sudo /usr/local/JKI/VIPM/vipm
  • To run this application it is necessary to have the LabVIEW2015SP1RTE module with at least 32 bits, since vipm is an ELF32 binary
  • Tested with LabVIEW-2018-SP1 linux, functional it allows to install packages, you only have to reconfigure labview since the instance of it that runs labview is in superuser mode.
  • It remains to allow execution in sudo mode through an icon to access the application, since it works in common user mode, the idea is to use gksu, but it does not work properly in gnome.
  • Missing to add icons and mime executables, to run the application from .vipm, .vim and .vipc file types.

__________________________________________________

 

VIPM-2017 compilación de paquete para Arch Linux y Manjaro Linux, mediante pkgbuild. FUNCIONAL y probado junto con LabVIEW-2018-SP1 (español)

 

Estimados colegas, a continuación les comento que he logrado hacer correr VIPM-2017 en Manjaro Linux (derivada de Arch Linux).

 

  • Actualmente lo he probado solamente con LabVIEW-2018-SP1 de manera funcional, pudiendo actualizar los repositorios de VIPM e instalando paquetes en LabVIEW.
  • Próximamente probaré funcionalidad en LabVIEW-2017 y 2019.

Adjunto enlace a mi repositorio en Github para que puedan "Clonar y Descargar". (en el archivo readme.md se encuentra una guía)
https://github.com/oschiant/pkgbuild_vipm-2017_Arch-Linux

 

Mucho gusto ser parte de esta comunidad y espero que funcione este paquete para ustedes!!!

___________________________________________________________________________

 

VIPM-2017 package compilation for Arch Linux and Manjaro Linux, using pkgbuild. FUNCTIONAL and tested together with LabVIEW-2018-SP1

Dear colleagues, below I tell you that I have managed to run VIPM-2017 in Manjaro Linux (derived from Arch Linux).

  • Currently I have only tested it with LabVIEW-2018-SP1 in a functional way, being able to update the VIPM repositories and installing packages in LabVIEW.
  • I will test functionality in LabVIEW-2017 and 2019 soon.

 

Attached link to my repository on Github so they can "Clone and Download". (a guide is in the readme.md file)

https://github.com/oschiant/pkgbuild_vipm-2017_Arch-Linux


I am delighted to be part of this community and I hope this package works for you.

 

vipm-2017_and_LabVIEW-2018_on_Manjaro_Linux.png

 

vipm-2017_and_LabVIEW-2018_on_Manjaro_Linux_2.png

 

Captura de pantalla de 2020-04-18 23-52-22.png

 

Captura de pantalla de 2020-04-19 00-08-45.pngCaptura de pantalla de 2020-04-19 00-09-00.png

 

 

0 Kudos
Message 1 of 2
(300 Views)
1 REPLY 1
Highlighted

Re: VIPM-2017 package compilation for Arch Linux and Manjaro Linux, using pkgbuild. FUNCTIONAL and tested together with LabVIEW-2018-SP1

what's new

 

https://github.com/oschiant/pkgbuild_vipm-2017_Arch-Linux

 

2020.04.18

  • Content is ordered and formats the README.md file to improve understanding.
  • Add dependency to the zensu package to be able to run vipm as superuser using the icon that is added to the Gnome applications. The user must belong to the wheel group to be able to run vipm in superuser mode. You can verify this by pasting the following command into a $ groups $ USER console.
  • In the future the idea is to run vipm as superuser using a polkit rule since it is the native authentication method of most graphical environments. See the following link https://wiki.archlinux.org/index.php/Polkit.

Running vipm from gnome:

 

vipm_application_gnome.png

vipm_gksu.png

vipm_gksu_2.png

vipm_gksu_3.png

 

With this update, there would be no need to run vipm from a console. (consider that it should be added to the Wheel group)

 

Good luck!!

 

 

 

 

 

0 Kudos
Message 2 of 2
(271 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.