Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted
Solved! Go to solution

USB-6009 support in ni-daqmx 18.1?

I'm pretty new to linux, and to NI. I have a USB-6009 and I would like to use it with linux. The readme for the NI-DAQmx 18.1 linux driver doesn't seem to list any USB devices, so I was wondering if it was even possible to use the USB-6009 in linux. 

 

Is my only option to use the very outdated DAQmxBase 15? That would require that I downgrade my OS and mess around with 4-year-old libraries.

0 Kudos
Message 1 of 3
(275 Views)
2 REPLIES
Solution
Accepted by topic author majesticerik
01-29-2019 02:45 PM

Re: USB-6009 support in ni-daqmx 18.1?

At the moment, there is no ability to use any USB DAQ hardware with the newer DAQmx drivers on Linux.

 

DAQmx Base 15 is the currently the best/only option for using that hardware in Linux.

 

Check out the DAQmx Base compatibility matrix though. It should support the current versions of CentOS and RHEL.

0 Kudos
Message 2 of 3
(258 Views)

Re: USB-6009 support in ni-daqmx 18.1?

Thanks. I'll have to look at switching from SUSE. I wasn't aware of that matrix.

0 Kudos
Message 3 of 3
(250 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.