Linux Users

Highlighted

Tcp/IP Error 1

Hello,

I am getting Error 1 at TCP read. I am getting this error since I created a TCP listener. My Vi worked fine when I had the TCP open instead of the listner. On checking, the Connection Id is same at probes 10, 11, 12, 13, 14

Attached is the vi. Please help.

Thank you. Error1.png

H.

0 Kudos
Message 1 of 4
(3,012 Views)
3 REPLIES 3
Highlighted

Re: Tcp/IP Error 1

You are mixing up two different wire types. Ideally we should have given you a broken wire here.

What you really want to do is use the "connection ID" output of the Wait on Listener primitive (bottom terminal) for doing your reading. The wire you're currently using is the listener ID (which can be reused to listen for another connection). Each time you get a new connection it gives you a new connection ID which can be used for reading and writing to that specific connection. They should also both be closed.

0 Kudos
Message 2 of 4
(2,456 Views)
Highlighted

Re: Tcp/IP Error 1

Thank you,

That was helpful

H

0 Kudos
Message 3 of 4
(2,456 Views)
Highlighted

Re: Tcp/IP Error 1

Hello,

 

https://forums.ni.com/t5/LabVIEW/Acquire-Bosch-IVAS-Sensor-Device-Ethernet-sensor-data/m-p/3994137#M... 

 

I am doing communication with TCP and reading data by UDP Reader.

I am getting following error on UDP reader

 

Error:

Error 1 occurred at UDP Read in Untitled 10.vi
Possible reason(s):
LabVIEW: (Hex 0x1) An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.
=========================
Command requires GPIB Controller to be Controller-In-Charge.
 
 
please help
 
Regards
Vishal kaushik
0 Kudos
Message 4 of 4
(599 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.