From 08:00 PM CDT Friday, August 12 - 01:00 PM CDT Saturday, August 13, will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Linux Users

Showing results for 
Search instead for 
Did you mean: 

Problem launching VIPM on openSUSE 15.1

I have installed openSUSE 15.1 on my laptop and on a VM.  In both cases, I am unable to launch VIPM.  When I try, an error message comes up:  Unable to open x display.


I have confirmed this behavior with both the Wayland and Xorg x servers (echo $XDG_SESSION_TYPE).


I have been successful in using VIPM with CentOS.  However, I would prefer to use openSUSE if possible.  If anyone has any suggestions, I would be open to trying them.  Please keep in mind that I am new to Linux, so please be patient with me.  Also, whatever I need to do to transition over to Linux for development will be better than what I am enduring using Windows.


Thank you!

0 Kudos
Message 1 of 10

Additional Information:


I installed openSUSE 15.1 (Desktop with KDE Plasma), then followed the instructions here to install support for LabVIEW 2015RTE 32-bit.  After extracting the archive files, I moved the /JKI/ directory to /usr/local/.  After running the INSTALL script, the message Installation Completed comes up, and no errors or warnings were displayed during the process.  I changed to the /usr/local/JKI/VIPM directory and entered 'sudo ./vipm' and the message "Unable to open X display" appears.  After typing 'echo $XDG_SESSION_TYPE' the response is "x11".

0 Kudos
Message 2 of 10

Hello DLJ,


Did you ever get this resolved?

I have the same issue as you and would appreciate your help.


Warmest Regards,


0 Kudos
Message 3 of 10

After some tinkering, I finally found a work-around for this problem.  Please keep in mind that I have just installed openSUSE as an operating system, and as such I did not have any personal files at risk here.


I downloaded and installed openSUSE 15.0 on my laptop.  After getting all of the updates, I followed the previous instructions to install the additional 32bit related packages.  Then I installed VIPM.  Please note the following responses from the terminal window:

     User Terminal:  Command: sudo ./vipm       Response:  Unable to open X display

     User Terminal:  Command: ./vipm      Response:  Do not have permission to open file

     Root Terminal:  Command: sudo ./vipm      Response: Unable to open X display

     Root Terminal:  Command: ./vipm      Response:  VIPM opens successfully!!


Once I verified that VIPM would open, I used a USB with the openSUSE Leap 15.1 installation files.  When the screen pops up, I selected UPDATE instead of INSTALL or BOOT FROM HARD DRIVE (see example here).  After selecting all of the default values, the system updated to Leap 15.1.  After rebooting, I verified that Leap 15.1 was installed, and checked for any additional updates.  Once that was done, I was able to successfully launch VIPM as root from a terminal window (see above responses).


I tested the above on a virtual machine first.  As an alternative, I used the example found here on the VM as well, with success in launching VIPM, though it was not the method I used to update my laptop.


For some reason, starting from a fresh install of Leap 15.1 does not allow VIPM to run.  When trying to launch, I get the Fatal Error 0x90FFFA4E error.  This has been the only way that I have been able to successfully launch VIPM in openSUSE 15.1. 


I hope that this works for you!

Message 4 of 10

Hello DLJ,


thanks for the follow up.


I've installed LV RT and the librarys mentioned, but unfortunatly I still can't launch VIPM. 




Second is the Terminal -Superuser Mode. Is that what you meant with Root Terminal?

Any other ideas?

0 Kudos
Message 5 of 10


Please remember, I started with a fresh install of openSUSE 15.0, then installed VIPM.  Once VIPM was installed and successfully running, only then did I upgrade to openSUSE 15.1.  Whenever I installed VIPM on 15.1, I always received the error you attached. 


When installing VIPM, I opened Konsole, and then switched to root using su root.  From there, I installed and ran VIPM.


If you can, I would suggest reinstalling openSUSE 15.0, installing VIPM, and then upgrading to 15.1.  Another option might be to downgrade to 15.0 and reinstall VIPM.  However, I have not tried this, so I cannot speak to its success.

Message 6 of 10

@DLJ wrote:

I started with a fresh install of openSUSE 15.0, then installed VIPM.  Once VIPM was installed and successfully running, only then did I upgrade to openSUSE 15.1. 

Thank you for the clarification! I didn't read it carefully the first time. After Installing openSUSE 15.0 instead of 15.1 and following the procedere VIPM is starting now.

0 Kudos
Message 7 of 10

I had the same problem using OpenSuse Leap 15.2

1) When I tried to run vipm using the command sudo ./vipm the error message Unable to open X display was shown.
2) When I tried to run vipm using ->./vipm (without sudo) the VIPM window pops up and then closes after few seconds.
3) When I tried to run vipm using -> gnomesu ./vipm the VIPM opens normally. 

I found the hint in the following link ->


0 Kudos
Message 8 of 10


I have the same problem but I cannot downgrade or reinstall openSUSE 15.1.

At this page

"VIPM 2020 for Mac and Linux are not yet released. Stay tuned."

So I wait for news for direct use VIPM on openSUSE 15.1 or for a new release of VIPM

thank you all


0 Kudos
Message 9 of 10

I'm having the same issue on my OpenSuse Leap 15.1


I installed LabVIEW RTE 2015 SP1 and VIPM

Then was missing, so I installed it manually

Then LibGL was missing, so I installed it manually


And now I'm stuck on this "Unable to open X display"

I've tried user and root with and without "sudo", no luck.


Then I installed gnomesu ($ sudo zypper install libgnomesu)
And now when I run "gnomesu ./vipm", I get this :


(gnomesu:13270): Gtk-WARNING **: gtk_window_set_titlebar() called on a realized window
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Fatal Internal Error 0x90FFFA4E : "AppEntryPoint.cpp", line 86
LabVIEW version 15.0.1f13
You will lose any unsaved work. For assistance in resolving this problem, please relaunch LabVIEW, or contact National Instruments.


Anyone solved this?

We have two ears and one mouth so that we can listen twice as much as we speak.


Antoine Chalons

0 Kudos
Message 10 of 10