Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.

OpenSuse 11.1 64Bit and NI-488.2 Installation Problems GCC

Hi, i have 2 Questions

1:  I read somewhere here that nikal dont run on a System with more then 4GB RAM , is this still true ? Becouse my System have 6 GB RAM

2:

I try to install the NI-488.2 on the OpenSuse 11.1 64bit with the Kernel linux-2.6.27.29-0.1.

I use the NI-488.2 2.5 Beta 64 Bit Driver.

After the sh ./INSTALL i get this error:

Continue? [Yn] Y

Checking required install tools...
Checking installer tool versions...
rpm        4.4.2.3 can be used with a default installation path
tar        1.20                                               
Checking dependencies...                                      
glibc      2.9                                                
Unpacking install files to /tmp/NI4882-2.5.4b1.install...   

******************************** ERROR ****************************************
* The version of gcc in the path does not match the version of gcc used to    *
* compile the currently running kernel.  This can cause unpredictable         *
* behavior in kernel drivers and should be fixed.                             *
* gcc version: Linux)                                                          *
* kernel compiled with: 4.3.2                                                 *
******************************** ERROR ****************************************

I cheked the Version of the GCC with gcc -v and its the same Version

Using built-in specs.
Target: x86_64-suse-linux
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.3 --enable-ssp --disable-libssp --with-bugurl=http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --disable-libmudflap --with-slibdir=/lib64 --with-system-zlib --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --program-suffix=-4.3 --enable-linux-futex --without-system-libunwind --with-cpu=generic --build=x86_64-suse-linux
Thread model: posix
gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux)

I tryed the solution here on the site. But it doesn help to edit the installerUtility.sh

I just get annother GCC error

By installing this software, you are acknowledging acceptance of the terms
of the included license file (LICENSE.txt).                            

Do you accept the license? [ynq] Y

linux-sapt:/home/hplogger/Desktop/release # sh ./install             

*****************************************************************************
  NI-488.2 Distribution                                                     
     version 2.5.4b1 for Li  ########################################### [ 43%]
   4:ni4882ki               ########################################### [ 57%]
   5:labview82-rte          ########################################### [ 71%]
   6:nispyi                 ########################################### [ 86%]
   7:ni4882i                ########################################### [100%]
Post Installation .                                                          
Warning: nikali post installation failed! /tmp/nikaliPostInstall.log follows:
******************************** ERROR ****************************************
* The version of gcc in the path does not match the version of gcc used to    *
* compile the currently running kernel.  This can cause unpredictable         *
* behavior in kernel drivers and should be fixed.                             *
* gcc version: Linux)                                                          *
* kernel compiled with: 4.3.2                                                 *
******************************** ERROR ****************************************
./uninstall.sh: line 13: Makefile.in: Datei oder Verzeichnis nicht gefunden    
Makefile:11: Makefile.in: Datei oder Verzeichnis nicht gefunden                
make: *** Keine Regel, um »Makefile.in« zu erstellen.  Schluss.                
Updating NI-KAL:                                                               
NI-KAL update failed.                                                         
                                                                               
Makefile:11: Makefile.in: Datei oder Verzeichnis nicht gefunden                
make: *** Keine Regel, um »Makefile.in« zu erstellen.  Schluss.                
                                                                               
ERROR: make of nikal kernel module failed, not installing kernel module.       
   updateNIDrivers should be called again after fixing the problem.            
   Logging failure...                                                          
   Include the file /tmp/niSystemReport.out.gz when contacting                 
   National Instruments for support.                                           
                                                                               
.........                                                                    

FOR PATENTS COVERING NATIONAL INSTRUMENTS PRODUCTS, REFER TO
THE PATENTS.txt FILE ON /home/hplogger/Desktop/release AND/OR
www.ni.com/patents                                        

******************************************************************************
* A reboot is required before attempting to use the                          
* NI-488.2 Distribution software.                                            
******************************************************************************
Would you like to reboot now? [yes|no] N                                     
Please input yes or no.                                                      
Would you like to reboot now? [yes|no] no                                  

NI-488.2 Distribution Installation completed with errors.

Please reboot manually before attempting to use
NI-488.2 Distribution software.

What else can I try to finish the installation ?

0 Kudos
Message 1 of 4
(5,356 Views)
3 REPLIES

Re: OpenSuse 11.1 64Bit and NI-488.2 Installation Problems GCC

1.  The 4GB of RAM limitation is only on 32-bit Linux.  64-bit Linux does not have this limitation.

2.  Installing the latest version of NI-KAL (Currently 1.10) then re-running the NI-488.2 INSTALL script should fix your problem.

Shawn Bohrer

Use NI products on Linux? Come join the NI Linux Users Community
0 Kudos
Message 2 of 4
(3,365 Views)

Re: OpenSuse 11.1 64Bit and NI-488.2 Installation Problems GCC

THX, very much. I will try it when I am back at work.

But is there anything that i should know, take care of any previous steps.

Just use the original installation script or the modifed script ?

And my first question was based on this KnowledgeBase etry " NI-KAL Fails to Load When I Have Greater Than 4GB of RAM " http://digital.ni.com/public.nsf/allkb/20789C3E4A3DCAFB8625708B00693CF9

is this problem solved in the new driver ?

0 Kudos
Message 3 of 4
(3,365 Views)
Highlighted

Re: OpenSuse 11.1 64Bit and NI-488.2 Installation Problems GCC

That KnowledgeBase still applies for 32-bit installations.  When installing NI-KAL and drivers that support 64-bit (NI-488.2 and NI-VISA) you will not have the 4GB limitation.

I assume at this point you have things installed, either by going back through installation after installing NI-KAL 1.10 or by running updateNIDrivers.

0 Kudos
Message 4 of 4
(3,365 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.