Linux Users

Highlighted

NIVXI Linux driver on newer kernels?

Hi, we are a big customer of NI VXI and PXI devices. We have like more than 150 systems.

Now we are upgrading the computors which talk to NI chasiss. We have install PXI driver on opensuse 11.3. It works fine. But VXI dirver (nivxi210p) cann't be installed on it. Linux kernerl used in openuse11.3 is 2.6.34.

I have ported the incompatable functions to new kernel, but it freezes evertime when I run vxiedit.

I am just wondering whether NI or anyone have this NIVXI driver working on newer linux sytem or whether there is a newer version of nivxi linux driver we can use.

Thanks in advance!

Jack

0 Kudos
Message 1 of 3
(1,651 Views)
2 REPLIES 2

Re: NIVXI Linux driver on newer kernels?

Wondering if there is any NI developer can drop a few words about the development status for NIVXI MXI card linux driver?

0 Kudos
Message 2 of 3
(1,184 Views)

Re: NIVXI Linux driver on newer kernels?


@jackzhang123

I have ported the incompatable functions to new kernel, but it freezes evertime when I run vxiedit.

I am just wondering whether NI or anyone have this NIVXI driver working on newer linux sytem or whether there is a newer version of nivxi linux driver we can use.

Thanks in advance!

Jack


Lockup usually smells like they did some weird things w/ interrupts. Ah, wait, interrupt handling heavily changed from 2.6 to 3.x.

 

Proprietary drivers nevery worked reliably. Don't even try that - it's russian roulette.

 

Linux Embedded / Kernel Hacker / BSP / Driver development / Systems engineering
0 Kudos
Message 3 of 3
(588 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.