Linux Users

Showing results for 
Search instead for 
Did you mean: 

NI-PCI 6225 and NI-PCI 6509 generate no data

I install both NI-PCI 6225 and NI-PCI 6509 on the motherboard and the os detected them:

[user@localhost ~]$ nilsdev --verbose
   BusType: PCI
   DevSerialNum: 0x129A763
   PCI.BusNum: 0x5
   PCI.DevNum: 0x2
   ProductNum: 0x716C
   ProductType: PCI-6225
   BusType: PCI
   DevSerialNum: 0x12BDE0D
   PCI.BusNum: 0x5
   PCI.DevNum: 0x1
   ProductNum: 0x7085
   ProductType: PCI-6509

The Cards are not connected to any source. I tried to read data from them and save it on a file, using C++ API (Code already tested using LabVIEW), but the problem is the output file is empty! So I guess the Cards generate nothing, even zero!

My question was, is such a scenario a normal behavior? Should I do something else, like a special command to start generating data?

0 Kudos
Message 1 of 2

I haven't worked with those cards specifically but no data definitely doesn't sound like the expected behavior.


Can we get some background info such as:

What distro/version are you using?

What NI drivers/versions do you have installed?

Is your code generating any errors as you try to set up your DAQmx task?


One thing that may be helpful in troubleshooting this issue would be to use an example program in LabVIEW to confirm the functionality of the drivers and the card. Once those are confirmed working, we could look further into your code to see if something isn't being executed properly.


0 Kudos
Message 2 of 2