Linux Users

cancel
Showing results for 
Search instead for 
Did you mean: 

CompactDAQ in Virtualbox

I am running Windows XP as a virtual OS inside Linux (Ubuntu 8.10), using Virtualbox 2.1.4.

In the measurement and automation explorer, I can see my NI cDAT-9172 chassis, but MAX reports that the slots are empty.  When I plug into a different computer running Windows, I can access the modules.

Do I also need to install DAQmx under Linux in order for the modules to be seen in the virtualized WinXP?  According to the README.txt distributed with DAQmx 8.1.0 for Linux, there is no support for USB devices:

* USB data acquisition products - Not supported. Refer to the "Support in NI-DAQ
  8.0.1" section for a complete list of supported devices.

Also, it seems that

  - Device subsystem routing table

might be required, but this is also unsupported in Linux.

Anyone have the CompacDAQ 9172 working in Virtualbox (host:Ubuntu, guest: Windows XP)?



0 Kudos
Message 1 of 3
(4,127 Views)

This information may or may not be useful:

I run LabVIEW 8.6 in WinXP as a guest OS within VirtualBox. My host OS is Windows 7. I have no issues connecting my NI cDAQ 9172 into the guest OS. I do have NI-DAQmx installed in both OSs though, so both can see it fine. All modules are visible and useable. Not tried running the VirtualBox guest OS on a Linux machine to see what happens yet, but maybe I will one day if I get a chance...

Thoric (CLA, CLED, CTD and LabVIEW Champion)


0 Kudos
Message 2 of 3
(1,901 Views)

CompactDAQ is not supported in Linux at all by the DAQmx 8.0.1 driver so I don't think having it installed will have any effect.  My guess is that it is some Virtual Box version, Windows Version, NI-DAQmx, USB communication thing.  From the sounds of it one person was unable to get this to work and the other one was.  I think it might be helpful to compare version information (Virtual Box Version, kernel version, libusb version (if that is what virtual box uses, maybe it accesses the USB from the kernel instead of user mode... I don't know enough about it), and Windows DAQmx version).  I know in NI-DAQmx 9.0 the way that cDAQ is recognized into Windows changed slightly so I wouldn't be surprised if the behavior changed between 8.9 and 9.0 of NI-DAQmx for Windows.

Regards,

Neil S.

0 Kudos
Message 3 of 3
(1,901 Views)