Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.
Highlighted

Can't get ni-daqmx driver to load for PCI-6013

Hello,

 

I'm new to both this group and to NI hardware. I am trying to get the NI driver for a PCI-6013 to load without success. I am running Centos 7.5.1804 (kernel 3.10.0-862.el7.x86_64). The system recognizes the PCI-6013 card:

 

[dnessett@localhost ~]$ lspci
00:00.0 Host bridge: Intel Corporation 82P965/G965 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82P965/G965 PCI Express Root Port (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82562V 10/100 Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HH (ICH8DH) LPC Interface Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corporation SATA Controller [RAID mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: NVIDIA Corporation NV43 [GeForce 6600] (rev a2)
03:02.0 Ethernet controller: D-Link System Inc DGE-530T Gigabit Ethernet Adapter (rev 11) (rev 11)
03:03.0 Unassigned class [ff00]: National Instruments PCI-6013

 

I installed ni-daqmx 18.1 and ran sudo dkms autoinstall. After rebooting, I ran  nilsdev , but it does not see the PCI-6013 card.

 

[dnessett@localhost ~]$ nilsdev --verbose
[dnessett@localhost ~]$

 

According to the documentation 18.1 should support the PCI-6013.

 

I have rebooted several times, but the card is not recognized.

 

Anyone have some suggestions what the problem might be?

 

Thanks,

 

Dan

 

0 Kudos
Message 1 of 4
(221 Views)
3 REPLIES

Re: Can't get ni-daqmx driver to load for PCI-6013

Hey Dan,

 

The PCI-6013 was released in 2002, so my first thought here is that we dropped support for it in the DAQmx driver at some point.  I agree that it is supported in DAQmx 18.1, but I think that's a Windows release (it's explicitly listed in the DAQmx 18.1 for Windows readme as supported).  

 

The most recent distribution of DAQmx that works on a CentOS system is the October 2018 Linux driver suite, which doesn't mention the 6013 as being supported.  I'd do some digging to see which of these two you have installed.  


It looks like the hardware is supported in NI-DAQmx Base 15.0, but that doesn't have support for your OS - only supports up to CentOS 7 with no support for minor versions.  If getting newer hardware is out of the question, you could try installing 15.0 onto your system but I'd foresee some amount of problems and potentially some bugs since the release is untested on that OS.  That said, I'm curious if anyone else on here has gotten B-Series hardware to work a CentOS version post-7.0.  

Matt | NI Systems Engineering
0 Kudos
Message 2 of 4
(209 Views)

Re: Can't get ni-daqmx driver to load for PCI-6013

Hi Matt,

 

Thanks for the reply. The version of NI-Daqmx I installed was the October 2018 version. I will try the 15.0 version and see if I can get it to work. Do I have to uninstall 18.1 first? If so, can you point me to the instructions for doing that?

 

Thanks,

 

Dan

0 Kudos
Message 3 of 4
(200 Views)

Re: Can't get ni-daqmx driver to load for PCI-6013

As far as I know, you can only have one version of a driver installed on a system, so yes you will have to uninstall 18.1.  

 

Since the .rpm file is installed through CentOS's native package manager, uninstalling should complete using the following command: 

 

yum autoremove ni-daqmx

 

Matt | NI Systems Engineering
0 Kudos
Message 4 of 4
(196 Views)
Reply
This is an open group. Sign in and click the "Join Group" button to become a group member and start posting.