Linux Users

cancel
Showing results for 
Search instead for 
Did you mean: 

2019 NI Drivers on ubuntu.

Highlighted

Cool, let me know how it goes

0 Kudos
Message 11 of 26
(917 Views)
Highlighted

So, tried running visa today and its not working again.  Not sure what has changed, but when i try to run visaconf i get the error libnipalu.so failed to initialize, verify that nipalk.ko is build and loaded.  nipalk.ko is built, and is located at /lib/modules/5.0.0-32-generic/kernel/extra/natinst  .  lsmod does not show it running, but i am able to load it with modprobe.  However, even after loading i still get the error.  Any ideas?

thanks!

0 Kudos
Message 12 of 26
(832 Views)
Highlighted

@dirtyb15 wrote:

So, tried running visa today and its not working again.  Not sure what has changed, but when i try to run visaconf i get the error libnipalu.so failed to initialize, verify that nipalk.ko is build and loaded.  nipalk.ko is built, and is located at /lib/modules/5.0.0-32-generic/kernel/extra/natinst  .  lsmod does not show it running, but i am able to load it with modprobe.  However, even after loading i still get the error.  Any ideas?

thanks!


It sounds like the nipal init script did not run.  Try unloading the nipalk kernel module (modprobe -r nipalk) and start the init script manually (/etc/init.d/nipal start).

0 Kudos
Message 13 of 26
(817 Views)
Highlighted

Hmm... there is no nipal inside of /etc/init.d

 

 

0 Kudos
Message 14 of 26
(787 Views)
Highlighted

@dirtyb15 wrote:

Hmm... there is no nipal inside of /etc/init.d

 

 


That would certainly explain why it didn't run.  😉  It sounds like something went wrong with the install.

0 Kudos
Message 15 of 26
(783 Views)
Highlighted

Any idea which rpm installs nipal? I assumed it was ni-pal but i don't get any errors when installing.

0 Kudos
Message 16 of 26
(781 Views)
Highlighted

ni-pal-support

0 Kudos
Message 17 of 26
(777 Views)
Highlighted

That was installed without any errors as well... At a loss,this used to work.

0 Kudos
Message 18 of 26
(774 Views)
Highlighted

Okay, i have it running again.

 

All i had to do was get the scripts that should have been installed in init.d 

I ended up copying them from a Centos8 machine i have set up.  I can provide them if anyone else needs them?

0 Kudos
Message 19 of 26
(763 Views)
Highlighted

I am seeing the same error.  I could use those files.  It looks like I need to get a machine to do a CentOS install for just this type of scenario. 

 

At the end of the my .deb install, I got the following.  I'm not sure if that has anything to do with it.

 

Errors were encountered while processing:
libnidrumc1-bin
ni-488.2-gpibenumsvc
ni-daqmx-ef
ni-pal-support
ni-roco
ni-visa-lxi-discovery

0 Kudos
Message 20 of 26
(708 Views)