LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

<built-in> <command line> macro names must be identifiers

I'm trying to build a project, but keep getting the following error. It seems to be occurring prior to entering my code, so I'm kind of confused. Does anyone have any guesses as to what the problem might be? Build Status (IMUTester_reciever.prj - Debug) IMUTester_receiver.c - 1 error, 1 warning 1, 1 In file included from : 139 1, 1 : 28:9: error: macro names must be identifiers Build failed. I am using a command line argument, which I've specified using the "Specify Executable and Command Line" dialog. I'm using CVI 2013.
0 Kudos
Message 1 of 19
(6,311 Views)
Arrgh! The error message got mangled when posted. Apparently anything surrounded by angle brackets is dropped. "built-in" and "command line" should have angle brackets around them, but I've dropped them for clarity. Here it is again: Build Status (IMUTester_receiver.prj - Debug) IMUTester_receiver.c - 1 error, 1 warning 1, 1 In file included from built-in: 139 1, 1 command line: 28:9: error macro names must be identifiers. Build failed
0 Kudos
Message 2 of 19
(6,310 Views)

Hey S2rt,

 

Do you have anything defined at the top of your c file with #ifndef, #ifdef, #define or anything like that? You would get that particular error if something defined starts with an underscore followed by a capital letter or starts with a number.

 

Kelsey Johnson

Applications Engineer

0 Kudos
Message 3 of 19
(6,268 Views)
None of my defines start with underscore or numbers. The error appears to occur prior to entering my file since the reference is to line 1, column 1. That said, my problem went away as mysteriously as it began. I don't know if it was saving the .uir as 7.1 format, or restarting CVI, or rebooting my system, or something else. So unfortunately I have no solution for others with this problem. Thanks.
0 Kudos
Message 4 of 19
(6,255 Views)
And just as mysteriously the problem returns. Still looking for an explanation...
0 Kudos
Message 5 of 19
(6,248 Views)

Hi guys,

 

I am having the same problem as S2rt. The error message looks the same. I get it for every file in my project using CVI 2013 with f1 patch, if I load the same .cws file in the CVI 2012SP1, everything works fine as expected.

 

I am using doxygen comments, so the files start like

/*! \file 
 * 
 */
#include <userint.h>
#include <ansi_c.h>

 but I also get this error code for the NI-WordReport Instrument.

/*============================================================================*/
/*                        L a b W i n d o w s / C V I                         */
/*----------------------------------------------------------------------------*/
/*    Copyright (c) National Instruments 1999-2013.  All Rights Reserved.     */
/*----------------------------------------------------------------------------*/
/*                                                                            */
/* Title:       WordReport.c                                                  */
/* Purpose:     Source file for CVI Word Report Generation Instrument Driver  */
/* Notes: 		This library communicates with the Microsoft Word Automation  */
/*				Server.  The Microsoft Word Automation Server must be first   */
/*				generated before using this library.						  */
/*                                                                            */
/*============================================================================*/

//-------------------------------------------------------------------------------------------------
//-------------------------------------------------------------------------------------------------
// Implementation Overview:

 Any news about this topic? Possibly a configuration problem or another bug in the 2013 release ?

0 Kudos
Message 6 of 19
(6,225 Views)

Problem goes away when using CVI7.1 or 2012.  As ichaus says, looks like another CVI2013 bug.

0 Kudos
Message 7 of 19
(6,211 Views)

Hi S2rt and ichaus,

 

Can you give me any background on what you are doing in CVI?

Does this happen any time you create a new project, or just with certain projects? Are there any other common factors, such as drivers you are calling or things being included?

S2rt, you said it happens before it even enters your files? Can you give me a screenshot of the build window? When the problem disappeared—did that mean you were successfully able to build it?

Any information you can give will help us work out if this is a bug or some kind of compatibility problem. Thanks!

 

Kelsey Johnson

Applications Engineer

0 Kudos
Message 8 of 19
(6,194 Views)

Hi Kelsey,

 

I have a project running over several years, always updating to the actual CVI version. As mentioned, when I load the cws file in CVI2013 I get this error, loeding the same cws file in CVI2012 everything works fine.

I tried the delivered wordrpt.cws CVI sample program in CVI2013, which also uses the above mentioned WordReport.c file. This is also working.

I tried two different computers, both showed the same error with my project and CVI2013.

Below I included my build output window, there I marked another error which occurs only in the CVI2013 release besides the already mentioned one:

 

BuildOutputCVI2013f1.png

0 Kudos
Message 9 of 19
(6,184 Views)
1. I'm writing a program that receives RS232 messages and lights up LEDs based upon the message content. It takes in a command line argument (I suspect that somehow CVI is garbling this process). 2. This is the only project I've tried in CVI2013. So far I'm unhappy and plan to wait until CVI2013 out of beta testing to use it any further. 3. First CVI2013 project. 4. Yes. The "command line" and "built in" references, combined with the column 1, row 1 location specifier lead me to believe that it occurs prior to parsing my files. 5. Attached. 6. Yes. 7. The only thing I can add is that the error does not appear in CVI7.1 or 2012.
0 Kudos
Message 10 of 19
(6,172 Views)