LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

IO Device error DAQmx -2147220719

Highlighted

I've been using an application developed in CVI 2013.  This application has been running using IO card NI PCI-6534 with no issues.  I then updated the IO card to the NI PCIe-6536B due to the PC not having additional PCI card slots.

 

When running the application I am able to run the IO tests about 2-3 times before getting the -2147220719 error.  I've attached a file "Capture.txt" and was able to know if anyone else has received these errors and was able to correct them?  TY!

 

0 Kudos
Message 1 of 3
(126 Views)

Hi BeauReed,

 

I am unsure if this helps, but have you tried resetting the NI-MAX Configuration database? I have seen a message that mentions that your error can occur if the database gets corrupted (maybe needs a longer delay between reading and initializing). Here is what you can eventually do. There is a warning message you may want to take a look at before you try this though

 

"Note: Use caution, as this procedure will delete all configuration data stored in MAX including DAQmx Tasks, DAQmx Global Virtual Channels, custom scales, and device configuration."

 

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P8awSAC&l=en-US

 

If that doesn't work, if you use NI-MAX manually to create and read from P1.6, do you see the same error?

 

Vincent

0 Kudos
Message 2 of 3
(87 Views)

Vincent

 

I've tried resetting the NI-MAX Configuration database with no luck.

 

I've created and read from P1.6 from the NI-MAX and I see no error, but it seems to be calling it in a different way, using DAQ function calls instead of DAQmx calls... Will research more.

0 Kudos
Message 3 of 3
(62 Views)