LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I link with ws2_32 or winsock?

Solved!
Go to solution

Currently, I'm reinstalling based upon this post.  This didn't work... Our IT does not allow connections to the internet.  I cannot activate correctly, though I did install a off-network node-locked license.  The installer does not seem to use it.  Now, I cannot even run LabWindows.

 

Previously, I couldn't seem to figure out how to link to Winsock.  I went into the bin directory where the other libs are located but my MSVC directory is empty.  Where are those located?  I have a full version license, but my Windows HKLM...type == Eval.  Also, my "eval" license is over.  SO, I'm not sure whether this is a licensing issue, an ignorance issue with adding windows libs to the project or an install issue.

 

If you have any light to illuminate my way, please shine on.

 

Andy

0 Kudos
Message 1 of 3
(151 Views)

Installing a second time...  Is there a DIFFERENT iso image to download?  I found the base,full and installed it.  Anyone?

0 Kudos
Message 2 of 3
(133 Views)
Solution
Accepted by topic author MAKennedy

Three points:

  • We have volume licensing which makes the install even more interesting.  The bottom line, however, is to delete everything out of your license directory except for your company's provide license file.
  • Not sure if NI installed this or if it came from another install that I've done, but the library files are located at:

C:\Program Files (x86)\Windows Kits\8.1\Lib\winv6.3\um\x86

 

  • If you have many files within your project tree, the container "lib" will off the screen at the bottom.  You must scroll down and add in the libraries you need.

 

0 Kudos
Message 3 of 3
(102 Views)