LabWindows/CVI

cancel
Showing results for 
Search instead for 
Did you mean: 

CVI Build of Lua

Hello everybody,

I want to load my DLL with your LuaCVI.lib, but I got this message:

 

ERROR:

dynamic libraries not enabled; check your Lua installation

 

In CVI I load my scriptfile - works fine:

 

    luaError = luaL_dofile(L, "bib.lua");
if (luaError){
fprintf(stderr, "%s\n", lua_tostring(L, -1));
lua_pop(L,1);
}

until I want to load my DLL :

 

require "myDLL"  -- in my scriptfile

 

 

Someone knows what to do?

I suppose I have to compile the lib new ... but I don't know what I have to change in the configurations.

 

 

 

Thanks

0 Kudos
Message 11 of 14
(1,007 Views)

solved ...

0 Kudos
Message 12 of 14
(976 Views)

I´m having the same problem. Neither _popen() nor _pclose() are recognized by CVI in the normal mode, by changing the calling convention to stdcall I run into problems with other CVI functions. How did you solve this problem in order to be able to load .dll files?

0 Kudos
Message 13 of 14
(900 Views)

Hi sensorizao,

long time ago your question - but I did not recognize.

So I can't remember (the flag in lua-source - sorry) ... but you can try to use my lib to load your lua-dll modules.

Good luck ...

 

#include <lua.h>
#include <lauxlib.h>
#include <lualib.h>
#include <luaconf.h>

and add my lib into project

 

0 Kudos
Message 14 of 14
(833 Views)