Showing results for 
Search instead for 
Did you mean: 

winspec and activex


Hi All,

     I have a windows 7 computer with labview 2010 (v10.0) and winspec 2.6.2, Im trying to control winspec in labview via ActiveX.  The problem I have is that whenever I try to call on a winspec library object (such as IExpSetup) I get an error saying that "Library not registered"


Winspec was never designed to run in windows 7, could it be that when you open winspec it doesnt properly register its classes and object in ActiveX in windows 7?


Thanks for all your help!!

0 Kudos
Message 1 of 17

Hi syampols,

  It is true that you must register any com dll or activex first.For that go to command prompt and type regsvr32 command followed by the winspec 2.6.2 com dll(This you will be accessing thorugh activex).Else use this utility i attached.


Thanks and regards,


0 Kudos
Message 2 of 17

Hi and thank you for the speedy reply, I have already tried the regserv32 thing and it doesnt work, mainly because it is an .exe file and all the objects are contained therein

0 Kudos
Message 3 of 17

Hi syampols,

  Whether Winspec uses any dlls or it is just an exe?Can you send the link ,where i can download the winspec and try.



Thanks and regards,


0 Kudos
Message 4 of 17

for the activex portion of the commands, just exe

0 Kudos
Message 5 of 17

hey, did you ever resolve this problem? I'm stuck at the same point.

0 Kudos
Message 6 of 17

Was a windows 7 problem in my case. works without problems in XP.

0 Kudos
Message 7 of 17

I had the same problem and could resolve it by running winspec.exe once as administrator. Then the activeX library got registered and it worked. However, I now have problems from time to time reading the spectrum (these I never had before on XP with the same code). So there might be still some issues with winspec on windows 7 computers. I would recommend running winspec on a dedicated XP machine.


Best wishes,


0 Kudos
Message 8 of 17

I did resolve it, I do not have any idea how, ill have a look

0 Kudos
Message 9 of 17

This is quite old topic but I will push it up.

I have winspec 2.5, We are changing to a new computer with windows 7, and I also have problems with registering ActiveX libraries under Win7.  Any hints?


0 Kudos
Message 10 of 17