From Thursday, May 23rd (05:00 PM CDT) through Friday, April 24th (1:30 AM CDT), 2024, will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.


Showing results for 
Search instead for 
Did you mean: 

unable to run Lock-In start-up kit

Hi,I am new to LabVEW software. I am working to design a Lock-In amplifier in LabVIEW. I have downloaded NI Lock-In start-up kit and tried to run in LabVIEW8.5. When the program is loading it is asking to fing some VI's,

"AI, AI Read(scaled array).vi, AI, AI", which I could'nt locate. Can some one help me with this?. In order to run this simulation do I need any hardware?.

Thank you,Hari.

0 Kudos
Message 1 of 10

Those VI's are part of the traditional DAQ drivers.  Only the DAQmx drivers are installed because they are the latest/greatest that you should try to use.


What you will need to do is reinstall from the Device Driver CD or DVD and select traditional DAQ support.

0 Kudos
Message 2 of 10

See this

Message 3 of 10
Thanks for the information. Can I get those driVers from NI site?, becasuse I donot have the CD. Also to run this Lock-In start-up kit simulation do I need to any hardware or just the LabVIEW software is enough?
0 Kudos
Message 4 of 10

The latest version of DAQmx can be downloaded from here. There is a built-in simulation capability with DAQmx and Measurement & Automation Explorer (MAX) which is the configuration utility for NI boards. The simulation is limited to a sine wave for analog inputs and there is no analog output available of course.

0 Kudos
Message 5 of 10

HI, I downloaded drivers from, I am still getting the same error, asking to loacte the VI's. Any suggestions?


Thank you.

0 Kudos
Message 6 of 10

Hi there, have you resolve this problem? I am getting the same error, and baffled by the missing subVi. Can anyone tell me where to get those missing files please? I would really appreciate it!!!


0 Kudos
Message 7 of 10

Did you download the Traditional DAQ driver as suggested above? When I do that, the Lock-In Demo VI is able to find the VIs that were missing previously.


Also, what version of LabVIEW and Windows are you using?



Brice S.

Applications Engineer

National Instruments

0 Kudos
Message 8 of 10

Hi there, thanks for your reply. I did download the traditional driver, however it still couldn't find those vi files. And I have labview 2011 that runs on windows 7, can they actually cause problems? 

Really appreciate your help!

0 Kudos
Message 9 of 10

Well, Traditional DAQ doesn't support Windows 7, so I'm suprised you were able to install the Traditional DAQ driver at all. The issue is that the Lock-In start-up kit is several years old and hasn't been updated to use DAQmx. I don't know if it provides all the same functionality, but there is Lock-in Amplifier example that was posted to our Developer Zone last year that you might find useful ( ).



Brice S.

Applications Engineer

National Instruments

0 Kudos
Message 10 of 10