LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

two FPGA Digital I/O malfunctioning

Highlighted

Hi,

 

I'm a student working on a semester project with PCI-7831R FPGA board.  I encountered an odd problem and I could not find anyone else posting the same problem.  I don't know if I fried two of the pins...

 

To get to the point, I am having problem with two of my Digital I/O pins.  I am trying to run a small 25cc internal combustion engine with LabVIEW/FPGA combo.  When I first got the board from school and tested DIO6 on MIO for hall-effect sensor signal (5V) for crank angle and it worked (the LED on front panel blinked as magnet was moved closer to the sensor), however DIO7 was also reacting to this.  So we decided to braid signal and ground wire to reduce noise.  This worked for a while (meaning DIO6 was fine), then started acting weird again.  We then decided to use +5V supply from the FPGA output to power the buffer and hall effect sensor.  This worked well, again, for a while and then it started skipping some signals.  We thought that was odd so we replaced the signal wire from hall effect to FPGA pinout-board (I think it's SCB68..), then it doesn't work anymore.

 

The hall-effect signal was verified to have ~5V using voltmeter, however, the voltage at the DIO6 is now reading less than 2V (about 1.3V).  It seems that something went wrong in the FPGA and is drawing current.  Of course the front panel LED icon is not responding anymore.  When we attach +5V supply directly to DIO6, the LED icon still does not turn on, meaning not responding.  Also, DIO7 is having basically the same problem, though 5V signal from hall effect reads about 2.3V.  When we recompiled FPGA to use DIO1, it works flawlessly.

 

We checked the wiring many many many times, making sure there was no short circuit, malfunctioning chip (such as buffer, hall effect sensor) and all common grounds are fed back to FPGA for referencing.  

 

What could be wrong? If anyone knows how to fix this problem, I would appreciate it!!  I am afraid I fried those two pins (or at least made it worse since others used the same board before, it is a check-out board from school).  Is there some sort of master reset to FPGA?  or some way to completely reconfigure everything and recalibrate so that this problem would go away??

 

Sorry for long post

0 Kudos
Message 1 of 2
(1,475 Views)

Muddybrown,

 

A few things for you.

 

"DIO6 on MIO(5V)...however DIO7 was also reacting to this."

If nothing was properly connected to DIO7, it is not surprising that it would react to a pin directly next to it.  This is normal behavior, however if you did have something properly connected to DIO7, then obviously we have some ghosting problems.

 

"We then decided to use +5V supply from the FPGA output to power the buffer and hall effect sensor."

Did you check the current draw of your sensors and the total current available from the board? I would check the User Manual on page 2-28.

 

"When we attach +5V supply directly to DIO6, the LED icon still does not turn on"

Do you have a multimeter to check the 5V output line to see if it is still providing a signal? If not, see the user manual for information on what to do.

 

Directly from User Manual: "Caution Do not short the DIO lines of the NI 78xxR directly to power or to ground. Doing
so can damage the NI 78xxR by causing excessive current to flow through the DIO lines."

 

I have never seen just 2 pins die on an R-series board, but I suppose it is possible.  Unfortunately, if those pins are fried, there is not much we can do besides using different channels or sending the board in for repair. 

 

There is no reset button for fried hardware...I would just try and be careful in the future, these boards are amazing devices, but must be handled carefully.

Rob K
Measurements Mechanical Engineer (C-Series, USB X-Series)
National Instruments
CompactRIO Developers Guide
CompactRIO Out of the Box Video
0 Kudos
Message 2 of 2
(1,439 Views)