LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

timestamp incorrect when transfer the data from LabVIEW 2010 to LabVIEW 2013

Hi, 

 

I am having problem when trying to transfer the timestamp from LabVIEW 2010.1 to LabVIEW 2013.0.

My host controller is running on LabVIEW 2010 and my client controller is running on LabVIEW 2013. 

My application need to read the host controller time and convert into U32 timestamp then pass it as a variable to my client controller using test stand. But the problem is when my client controller read the timestamp it is actually incorrect. 

Is this a LabVIEW bug?

 

The first attachment is the screenshot of front panel of labview 2010.1 and the second attachemnt is front panel of labview 2013.0. 

 

Thank you. 

Download All
0 Kudos
Message 1 of 3
(1,087 Views)

Hi Isaac,

 

have you ever considered DST (daylight saving time) with your timestamp data? It's just a one hour offset that should give you a hint on it!

 

- How do you convert from timestamp to U32 and vice-versa?

- Did you do anything to use "universal time" instead of local time?

- Did you read the LabVIEW help on this topic?

 

And last, but not least: Did you know "screenshot" could be done without using a 16MP camera some centimeters in front of your monitor? Did you know you could reduce image resolution to attach pictures smaller than 4MB?

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 2 of 3
(1,071 Views)

HI GredW,

 

Thank you for your reply and indeed by unchecking the DST in windows resolved the problem.

 

Regards,

Isaac

0 Kudos
Message 3 of 3
(1,027 Views)