LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

time stamp

Solved!
Go to solution

Hi,

 

I noticed an interesting case of using timestamp. I create my applicaiton in Window XP English version. When installed the created installer in French version, the generated current time has different order. In english version, it is month/date/year by default, but on the PC with French version, it is Date/Month/Year. Does any one have any idea on how to fix it? How could I find out the window version is french or English?

Thanks,

Ott

 

 

0 Kudos
Message 1 of 5
(1,547 Views)

The data itself does not change, only the representation is changed.

By default the representation is a local one (%z), to get a system independent time representation have a look at  the Time format codes.

 

Ton

Free Code Capture Tool! Version 2.1.3 with comments, web-upload, back-save and snippets!
Nederlandse LabVIEW user groep www.lvug.nl
My LabVIEW Ideas

LabVIEW, programming like it should be!
0 Kudos
Message 2 of 5
(1,524 Views)
LabVIEW timestamp representations default to the SYSTEM time display format.  just change either the system settings OR create a strict type def that specifies the desired representation.

"Should be" isn't "Is" -Jay
0 Kudos
Message 3 of 5
(1,511 Views)

Thanks.

 

By the wy, I checked the Data and Time setting in the control panel. They are the same.

 

Where should I make the change?

 

Thanks,

Ott

0 Kudos
Message 4 of 5
(1,503 Views)
Solution
Accepted by topic author Opt_Ottawa
In that case

Opt_Ottawa wrote:

Thanks.

 

By the wy, I checked the Data and Time setting in the control panel. They are the same.

 

Where should I make the change?

 

Thanks,

Ott


You will need to make a strict type def to hold the display style.  Then replace each time stamp front pannel object with the type def.  


"Should be" isn't "Is" -Jay
0 Kudos
Message 5 of 5
(1,499 Views)