LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

termination character enable

I am connected to hardware via an RS-232 cable and am using VISA’s to request and read information from memory addresses. When I encounter a 0x0a (hex) in memory, the VISA Read stops reading because it thinks it has read the termination character. This only happens when a 0x0a is encountered, all other characters from 0x00 to 0xff are read in correctly (provided there isn’t a 0x0a in the location).
I have set the Termination Character Enable property node to FALSE and it doesn’t seem to help (Ver 6.0.2). Any help on disabling the Termination Character would be appreciated.

Thanks,
DH
0 Kudos
Message 1 of 4
(2,051 Views)
I would think that setting the Termination Character Enable to false would prevent this. Maybe something else is turning it back on. If you use the VISA Configure Serial Port.vi (In instrument I/O>>Serial) it will turn this setting back on. So make sure you turn it off after any of these functions. One other thing that have done is set the Termination Character to 0x00, although I'm not sure what would happen if you got a 0x00 (NULL?) back from the port. Also check for other functions that may alter these settings after you set them.

Hope this helps!
Brian
0 Kudos
Message 2 of 4
(2,051 Views)
I set the Property node after the VISA Configure Serial Port.vi and added the Serial End In Mode property to None(0) and it seems to work.

Thanks.
0 Kudos
Message 4 of 4
(2,051 Views)
DH:

You also need to set the Serial End In Mode property to None(0). This property allows the Serial VISA code to treat termchar (by default) just like EOI in GPIB. Changing it to None(0) means that the termchar character will be treated like any other.

By the way, the VISA Configure Serial Port VI in LabVIEW 6.1 sets this property correctly so you don't have to worry about it.

Dan Mondrik
Senior Software Engineer, NI-VISA
National Instruments
0 Kudos
Message 3 of 4
(2,051 Views)