Showing results for 
Search instead for 
Did you mean: 

sweep voltage keithley 2400

Go to solution

Hi friends,


I´ve made a small program (re-using one I found in the web) in order to generate an IV curve using Keithley 2400. I want to sweep voltage from -1 to 1V using for example 10 points and obtain the current both in a graph and in a table.


However, something is wrong because I only get one measurement (not even correct) and no image in the graph and no data in the table.


Could someone advise me here, please?


Any help is welcome!


Thanks keithleydoubt.PNG

0 Kudos
Message 1 of 10
Recommendation 1: Show us your code.

It is very difficult to troubleshoot a picture -- and doubly so when the picture doesn't show all the code.


Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 2 of 10

Hi mikeporter, 


I´ll attatch the code in a while. However, the rest of the code is just for moving some motors meanwhile the picture shows the measurement process. The problem is that I have to move motors, measure, move, measure,... and let the code running for days without interaction, so the examples I found on internet don´t solve my problem. 



Message 3 of 10

Hi lacorgui,


why do you create a double post on this topic?

You already have shown your VI in this thread of yours!


Stick with one thread when it handles the same VI and the same problem!

Best regards,

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 4 of 10

Hi GerdW,


I know it can seem the same, but in the other post I also was asking for movement of motors. Now is just sweep V-I measurement. I´m sorry if I double posted it, but here I am not asking about motors code. Should I close this and return to the other one? (not really sure how to make it)



0 Kudos
Message 5 of 10

Hi mikeporter,


attached is the code! Feel free to take a look (don´t be scared, I know is a dirty-made codeSmiley Embarassed). My problem is on the measurement stage using Keithley drivers (I guess).


Thank you very much

0 Kudos
Message 6 of 10

You should keep you questions related to a particular VI to a single thread, but I will give you a couple things to look at:


  1. Is the loop is stopping after just a single iteration?
  2. Is the state machine continuing to run but is not getting back to the Measurement state?



Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
Message 7 of 10

First, thanks for the advice (I though that I had to create another post, sorry for this misunderstanding). 


About your "questions", 


The program runs for the different stages using the loop correctly, the problem is how to adquire the measurement data (it starts moving to one given position, then measurement should be done, move to next position and repeat). 


I´d like to have more programming skills because this is killing me softly Smiley Sad


0 Kudos
Message 8 of 10
Accepted by lacorgui

Hi LabVIEWers, 


I´ve got a problem receiving data from Keithley 2400. 


I´m using a distributed Keithley LabVIEW example ( attached ) and suddenly it does not work. When I run the program it sends the information to the Keithley and a sweep is made. The problem is when the sweep is made, no data come back to the program so I can not save any data or see any result in a graph or in a table. 


I´ve tried to debbug the program using the highlight option, and it gives me that the data goes to the graph but I got nothing (just #0 in the ouputs of the last subVI before the graph).


The strange thing is that this program has work until now, any idea what can be the problem??


Thanks very much!!

0 Kudos
Message 9 of 10



Can you provide the VI. I am having problem including the sweep rate in my VI.


Thank you,


0 Kudos
Message 10 of 10