LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

subVI drag-drop copy from it's icon onto a caller block diagram -buggy?

Hey all, 

I'm using LabVIEW 2016 that I recently installed, and I've noticed something I can't remember ever having an issue with before:

 

I (somewhat) frequently want to place a subVI onto a calling block diagram by "left-click and hold" on the subVI icon, and dragging it to the intended to be caller's block diagram.  

 

Fairly consistently this fails even though the mouse icon shows the expected "+" symbol while dragging, when I let go of the left mouse button, nothing happens, the subVI does not drop.

 

I've tried to nail down the root of the problem (playing with the path that I drag the cursor over by avoiding certain areas, what bounds I exit (top window border, left, right, avoiding the subVI toolbar while dragging, etc. etc.) but every time I think I observe a pattern, a couple of drag-copy's later, it fails, even if I did not change the path.

 

I've also tried playing with relative window positions (e.g. the subVI window overlapping or not overlapping the drop-target window). 

 

Am I just going crazy or did something happen to this functionality in 2016?  Has this always been an issue and I have just somehow changed my workflow in a subtle way that now makes me more suceptible to this issue? 

 

Has anyone else seen this behavior and/or figured it out?

QFang
-------------
CLD LabVIEW 7.1 to 2016
0 Kudos
Message 1 of 12
(2,134 Views)

I've seen stuff like this when LV wasn't installed as admin or run as admin.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 2 of 12
(2,099 Views)

I'm fortunate(?) enough that I'm my own local admin on my job computer. 🙂

QFang
-------------
CLD LabVIEW 7.1 to 2016
0 Kudos
Message 3 of 12
(2,091 Views)

NI, have you found a solution to this yet?  I'm noticing this too and am an admin.  A bit annoying.

 

EDIT:  I've noticed that it usually happens when I click and drag the icon from the block diagram window.  Front panel icon works OK.  

 

In LabVIEW 2015 SP1 you can click and drag from either the FP icon or BD icon.  Looks like a LabVIEW 2016 bug.

Message 4 of 12
(1,790 Views)

I've tried this too and get the same behavior on my machine.  2015 works, 2016 does not.  Have you guys found a workaround for this?

0 Kudos
Message 5 of 12
(1,783 Views)

It seems to be primarily an issue if I try to drag-drop the icon from the 'block diagram window'. If I drag the icon from the front panel window it seems to 'always' work.  

 

So whenever I encounter this issue these days (which is NOT 100% of the time), I just grab it from the FP and drop it where I need it and go about my day.  My impression is that NI is unlikely to fix this annoyance since the next version of LV has a completely re-worked IDE anyway.

QFang
-------------
CLD LabVIEW 7.1 to 2016
0 Kudos
Message 6 of 12
(1,776 Views)

Theoritically 2016 SP1 should come out any day now.  Maybe we'll get lucky and see it fixed there.  It's frustrating that a core capability that has been there for a long as I can remember (back to 5?) all of the sudden no longer works.  Especially since we will likely be using 2016 for several years here.

0 Kudos
Message 7 of 12
(1,762 Views)

Oh I hear you! No argument from me.  Still, for me it went from a major source of frustration to a minor once I found out how to reliably work around this new 'feature'. 😉

 

As far as my comment on them fixing it or not, that may just be me moderating my own expectations on this, but you are correct, it is possible a SP1 could fix this. . . Speaking of, does anyone know if SP1 schedule might have changed when they moved NI Week to May and the teased product release they have planned?

QFang
-------------
CLD LabVIEW 7.1 to 2016
0 Kudos
Message 8 of 12
(1,756 Views)

I have noticed this as well.  I would consider it a bug.  Someone from NI please comment and issue a CAR for this.

 

(Why would functionality like this disappear from 2015 to 2016?)

0 Kudos
Message 9 of 12
(1,710 Views)

Hi everyone,

 

Thanks for pointing this out. I was able to replicate it as well. As far as I can tell, this is indeed a bug, not a "feature." I'll go ahead and file for a CAR.

 

I've tested it on Windows 7 64-bit. Are you guys using anything else? I can add those as OSes we've seen it on.

 

Also, for me it always works from the front panel, and from the block diagram if I try it twice. (If I try it four times in a row, it works on tries two and four.) If you guys are seeing anything else in terms of patterns, let me know. I'll try to replicate those patterns as well.

William R.
0 Kudos
Message 10 of 12
(1,687 Views)