LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

sub vi opening with main vi

This exact question was asked before, but the solution doesn't help me.

http://forums.ni.com/t5/LabVIEW/why-does-my-subvi-open-when-I-open-my-main-vi/td-p/1473974

 

When I open the main program from windows explorer, it brings up the front panel of one of the sub vis as well. I have checked the "window appearance" properties for both of the Vis, and neither of them have either "show front panel when loaded" or "show front panel when called" selected.  Any other suggestions?

0 Kudos
Message 1 of 4
(1,215 Views)

You can open the front panel in several ways, one being VI properties of the vi itself. You can also set the "Call setup" of the sub vi in the calling vi, and then you have pure functions, as Invoke node.

 

/Y

G# - Award winning reference based OOP for LV, for free! ADDQ VIPM Now on GitHub
"Only dead fish swim downstream" - "My life for Kudos!" - "Dumb people repeat old mistakes - smart ones create new ones."
Certified-LabVIEW-Developer
0 Kudos
Message 2 of 4
(1,200 Views)

My problem isn't opening it up. Making it open is easy - by all of the methods you mentioned.  My problem is getting it to NOT open.

 

It also opens on load even when built as an application, which is where the problem comes in. I don't want it to open when the user starts the program.

0 Kudos
Message 3 of 4
(1,189 Views)

Well, you need to double check none of the above options are activated, or did you manage to set it as opening vi in the built application?

/Y

G# - Award winning reference based OOP for LV, for free! ADDQ VIPM Now on GitHub
"Only dead fish swim downstream" - "My life for Kudos!" - "Dumb people repeat old mistakes - smart ones create new ones."
Certified-LabVIEW-Developer
0 Kudos
Message 4 of 4
(1,167 Views)