LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

slow loading time of Labview executable application on pc without labview enviroment !

Solved!
Go to solution
Highlighted

hi !

i have made an executable file of my project.

when i run it on my pc (where labview development installed) i have no problems and the application loads instantly.

 i tried to run the same exe on several other computers, all having the same trouble - the front panel poped up after 2 minutes of waiting.

i did a little test and pluged out the network cable - it solved the problem, but i need the network.

i tried to disable automatic root certificate update (like advised on some thread) but no luck.

i searched the forums and found similar problems - but no solutions.

please help me .

guy.

0 Kudos
Message 1 of 14
(3,255 Views)

Does the executable need the network? I am assuming that you probably have some sort of anti-virus software that is interfering with the startup if that's the case? Let us know more about what the executable is doing.

Adnan Zafar
Certified LabVIEW Architect
Coleman Technologies
0 Kudos
Message 2 of 14
(3,253 Views)

I've had this problem before, but it eventually dissapeared.

I'm not sure if it was a LabVIEW update that fixed it, but I remember I never had to deal with this again.

 

Let me know what version of LabVIEW you're using and I might be of more help 🙂

Jorge
0 Kudos
Message 3 of 14
(3,249 Views)

i have udp open/read/write functions in it but their code in the block diagram isn't initiated until i press a button.

i have labview 2010.

0 Kudos
Message 4 of 14
(3,223 Views)

Is your problem solved? I too have the same issue and very badly in need of a solution/workaround.

0 Kudos
Message 5 of 14
(3,158 Views)
Solution
Accepted by topic author hookso
Yes. Problem solved.
first disable the auto root certificate update-no problem to find how to do this.
Then type regedit at Start-Run, my computer-hkey current user-software-microsoft-windows-currentVersion-winTrust-trust providers-software publishing- right click on State-modify-change the c character to e then press ok.
Good luck and let me know if it helped.
0 Kudos
Message 6 of 14
(3,154 Views)

@hookso wrote:
Yes. Problem solved.
first disable the auto root certificate update-no problem to find how to do this.


 

Would you be able to share how to disable the auto root certificate update?

I may not be perfect, but I'm all I got!
0 Kudos
Message 7 of 14
(2,958 Views)

Google it - it's there on the first result

0 Kudos
Message 8 of 14
(2,934 Views)

Is this a one-of machine, or are you going to force all your customers to do this?

0 Kudos
Message 9 of 14
(2,928 Views)

you have to do it on every pc.

for me it's ok because i'm the customer of myself.

if you have many customers that have to install the same application, it's not best solution but the only one i could found. 

0 Kudos
Message 10 of 14
(2,925 Views)