Showing results for 
Search instead for 
Did you mean: 

sharied variable, myrio, error 1950679035

So I am using a myrio and want to pass some data to it from the controller I plugg into my computer. The problem I keep running into is this error 1950679035. I looked it up online and the two fixes for it are a longer wait time, didn't work, and going around the fire wall, didn't work. The only other way I know of fixing this is to use the udp blocks instead of shared variables but to do this I believe I lose my ability to keep the data type I need to tell the motor driver to turn the motors. The shared variables are network published and the data type is unsigned byte.

0 Kudos
Message 1 of 7

Are you sure the Shared Variables got deployed on the RT side?  That is what I would first suspect to be your problem.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 2 of 7

I don't entirely know what you mean by RT side. If you mean putting those variables in the myrio portion of the code then I tried that and it did not work.

0 Kudos
Message 3 of 7

Where is the library in your project?  Is it under the myRIO (The RT portion of your project) or is it under the "My Computer" portion? 


If you go to Tools->Distributed System Manager, can you see the variables in there? 

0 Kudos
Message 4 of 7

The library is in the computer portion and the variables can be seen. I you look at the controller picture I posted they can be seen in the project in the bottom left hand corner. I can move it to the myRIO section of the project but I have tried doing that before and it didn't work. 

0 Kudos
Message 5 of 7

Here is a picture, I hope this helps.

0 Kudos
Message 6 of 7

Hi rigger,


Your myRIO is running a real-time processor, so this is what we are referring to when we say “RT side.” I’ve done a little research on that error, and it turns out that LabVIEW is having trouble finding the variable in the Shared Variable Engine (I’ve attached a link below that talks about what this is), and that deployment of this variable (or variables) may have failed.


Using the LabVIEW Shared Variable:


Take a look at this other forum thread, as it also addresses this particular error you are seeing. Look at post number 5; have you deployed your variables/libraries similarly?

Ross S.
Applications Engineering
National Instruments
0 Kudos
Message 7 of 7