LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

set up a CompactRIO - the LabVIEW real-time module does not appear

Solved!
Go to solution

Dear NI,

 

I am trying to set up a CompactRIO (cRIO-9054).

 

I am using 32 bit LabVIEW 2017 SP 1

 

My issue is that when I get the stage in Max to install software, the LabVIEW real-time module does not appear in the list of software that I can install, and everything depends on the LabVIEW real-time module so I can't install anything.

 

When I try to install NI-RIO 19.6 I get the error message:
"NI-RIO 19.6 requires LabVIEW Real-Time 14.0"
"Possible reason: The feature's Real-Time support for this target type may not be installed"

 

My reasoning is that the LabVIEW real-time module should appear in the list of software that I can install and the dependencies should automatically include it when i choose to install NI-RIO 19.6


Here are some details of what I did.


At first I used an existing installation of LabVIEW that I had installed LabVIEW softmotion, LabVIEW real-time module, LabVIEW FPGA module, and the NI CompactRIO Drivers.

 

There were several other modules installed, namely:
gpower
mgi
openg
Nidaq1760f
NI-Motion
Ni-Visa 18.5
VAS1800
Cambridge SDK

 

I used Max to install firmware where I was directed and used the file "cRIO-9054_7.1.0.cfg"
I read online that the correct firmware should be found there.
Is this the Correct File/Version? I can't see where the firmware versions are mention on NI.com.

 

When I used MAX I encountered the problem mentioned above

 

I tried reinstalling LabView Real-Time module, re installing the NI CompactRIO Drivers and had the same problem.

 

So, I tried un installing LabVIEW and installing everything again

 

To uninstall, I used the Package manager where i selected everything except for the package manager and uninstalled everything there.

 

I then went to control panel -> uninstall programs and uninstalled Cambridge SDK, all IVI programs, and all VISA programs.
I un-instaled the package manager.
I rebooted

I then deleted the National Instruments folder in "Program Files (x86)"


I Followed the directions on this page:
http://www.ni.com/getting-started/install-software/compactrio

 

And installed, in this order:
LabVIEW Full Development System 2017 SP1
LabVIEW Real-Time Module for LabView 2017
LabVIEW FPGA Module for LabView 2017 SP1
NI CompactRIO Device Drivers (file ni-compactrio-device-drivers_19.6.0.49154-0+f2_offline)

I then went back to Max and found that it had remembered my CompactRIO device (it was shown in the list of remote systems even though it wasn't plugged in).

 

I connected CompactRIO and went to software, and experienced the same problem as above.

 

Please can you help me out?

 

Thanks,
Cameron

0 Kudos
Message 1 of 3
(564 Views)
Solution
Accepted by topic author CameronFromPerth

Hello Cameron,

 

The cRIO-9054 is one of our newest products in the CompactRIO field, and therefore requires LabVIEW 2018 or higher.

 

You can find more information here: Software Support for CompactRIO, CompactDAQ, Single-Board RIO, R Series, and EtherCAT and cRIO-9054 Controller Manual 

 

Regards,

0 Kudos
Message 2 of 3
(502 Views)

Thanks Oscar

 

I was able to get passed that issue by installing LabVIEW 2019

 

Cheers,

Cameron

0 Kudos
Message 3 of 3
(486 Views)