LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

running Lego Mindstorm with Labview 2019

Solved!
Go to solution
Highlighted

Hi All,

 

I have Lego Mindstorms I use for a teaching Lab.

This year I have had to upgrade my PC's to Windows 10 so I installed LabView 2019 while I was at it.

Now however I realise the 2016 version of Labview is the last one supported for Lego.

When I log into my N.I. account I cannot download Labview 2016 version.

Did anyone else have this problem and if so how did you get around this issue or is there a link to download

the older version as the option is removed from my download profile.

 

thanks

Denis

0 Kudos
Message 1 of 7
(267 Views)

Are you affiliated with a University or other academic institution?  Might they have an academic license you could use?  Have you tried calling NI and asking their advice in your situation?  I would hope they would be sympathetic to using LabVIEW as a teaching tool ...  You might also try calling the Lego/Mindstorm people.

 

Bob Schor

0 Kudos
Message 2 of 7
(238 Views)

I would call NI, because if you have a valid serial number for LV2016 then you should still be able to download and use LV2016.

-------------------------------------------------------------------
Unfortunately, most readers of this Forum, including some real Experts, have not mastered the skill of being able to read the code that Posters fail to post. If we cannot see "what you did wrong", we are unable to tell you how to fix it. (Bob Schor 28 August 2018)
0 Kudos
Message 3 of 7
(201 Views)

Hi Bob,

Thanks for your reply,

Yes we have a license for LabVIEW the problem is the last Driver - addon pack available for the Lego

Mindstorm is 2016 version of LabVIEW which I can't seem to download from N.I.

There has to be a workaround out there its just trying to find it

 

D

0 Kudos
Message 4 of 7
(142 Views)
Solution
Accepted by topic author DenisMoore

This might explain my situation better

I am new to this particular lab so any advise is gratefully received

 

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P80ySAC&l=en-IE

 

D

0 Kudos
Message 5 of 7
(137 Views)

I would assume that package came as VI's or a DLL so it'd work on any newer LV? Maybe it can? I remember installing some addon on an old LV (it didn't have official support for my preferred version) and simply copy the folder to a newer LV and do a mass compile. Unofficial ofcourse, but it worked. Smiley Happy

This process is ofcourse depending on the addon being normal LV code or the right bitness in case of DLL based.

(I think it was the DB toolkit i installed on a 64 bit LV this way)

/Y

G# - Award winning reference based OOP for LV, for free! ADDQ VIPM Now on GitHub
"Only dead fish swim downstream" - "My life for Kudos!" - "Dumb people repeat old mistakes - smart ones create new ones."
Certified-LabVIEW-Developer
0 Kudos
Message 6 of 7
(132 Views)

I finally found an old install for 2016 all is good

 

Thanks All

0 Kudos
Message 7 of 7
(110 Views)