LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

red color detection using a web cam

i have by hit and trial made code plz any1 chk it thats what the mistake in it.when i run it ma system stops responding =(
i have done the following things:
1)the camera is continuously looking at all the sequence of images.
2)i have coupled an imaq color learn vi with an input image of a red color made in paint and saved as JPEG image.
3)The color spectrum obtained of this red color pic is then compared with the image from the webcam in the imaq color match vi
4)if its output is true then that image is obtained on the screen.

but its not happening.help me out plz.

 

i am ataching ma vi also.im using lab view(8.2)

i need serious help.

0 Kudos
Message 1 of 8
(4,033 Views)

Hi,

Your VI will hang up surely.

1. You have wired the 'image out' from first loop as input to second loop.  Your second loop will get data only when the first loop stop executing.  The first loop will never stop because you have wired a 'True constant' with 'Continue if TRUE' condition for while loop.

 

I have modified it to avoid dependancy.  Change the code as per your needs.

Post back for queries.

With regards,
JK
(Certified LabVIEW Developer)
Give Kudos for Good Answers, and Mark it a solution if your problem is solved.
0 Kudos
Message 2 of 8
(4,016 Views)
duplicate issue
Alex Person
NI-RIO Product Support Engineer
National Instruments
0 Kudos
Message 3 of 8
(3,991 Views)

yup i checked those examples.thanks your advice was a big help tto me.i have modified the code but a strange error is coming.

 

an exception occured within the external code called by a library function node.this might have corrupted labview's memory.save any work to a new location and restart labview:
"name ".vi was stopped at node " " at a call to "IMAQ USB INit.vi"

 

i restarted lab view but again the same error.actually i am trying to compare the colors of an imge taken by a web cam and an image loaded from memry.i am attaching the vi.plz do chk and rep soon.=(

0 Kudos
Message 4 of 8
(3,980 Views)

Hi armank,

 

Please post each issue in one thread only.   The duplication of issues makes things harder to follow for both those who are trying to help and those who are trying to learn from your issue.  Please see my response here.

Stephen Meserve
National Instruments
0 Kudos
Message 5 of 8
(3,975 Views)

can anyone check whts the mistake to get red detection with my circuit...ASAP please...

0 Kudos
Message 6 of 8
(3,147 Views)

duplicate issue

Applications Engineer
National Instruments
0 Kudos
Message 7 of 8
(3,119 Views)

I have a copy of the remastered versino of the Wizard of Oz. They went back to the original neagtive cleaned them up resampled and then went the next step of adding logic intended to auto-remove flaws occuring in one of the negatives that do not apper in the others two negatives. The results were impresive (you can see the emu's in the background behind the cottage where the Tin Woodsman was found!) but it also automatically removed Dorthy's shoes!

 

Ben

 

PS: Yes i am running tests and playing tag today. Smiley Wink

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 8 of 8
(3,117 Views)