LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

"Use fast file format" breaks remote front panel access

Hi all,

 

I just figured out what was causing me problems with remote front panel access to a built Windows .exe, and I thought I'd document it here for anyone else who comes across it. I was rebuilding in LabVIEW 2017 an application that had last been built several years ago, and when I tried to connect to its front panel remotely, my web browser popped up an error dialog:

 

LabVIEW: Resource not found.

An error occurred loading VI 'lvfpp0.vi'.
LabVIEW load error code 17: Could not load VI's link information.

 

I couldn't find much on "lbfpp0.vi" or "error code 17" and neither could NI support, so I started experimenting. I tried building in LV2015, 2016, and 2017; 32- and 64-bit; on different computers, and using different browsers. However, they all gave the same error. As far as I could tell, the problem was something inherent to my project, though I had never had this problem in the past. Then I started checking and unchecking boxes in the application build properties, and I found that unchecking the "Use fast file format" box fixed the problem. I had gotten in the habit of enabling it since it was added in LV2015 and had done so before rebuilding this old project, but this was the first time I'd tried to use remote front panel with it. Has anyone else had this experience?

 

Aaron T.

 

Message 1 of 11
(2,056 Views)

Hey Aaron, thanks for posting this! I haven't been able to find this specific issue in our documentation, though I've found a similar Corrective Action Request related to checking "Use fast file format" causing a problem that should have been fixed by LabVIEW 2016. So if this is reproducible in LabVIEW 2017, we definitely want to reproduce this.

 

Just to clarify a couple things:

 

1. When you have the error coming up, is "Enable debugging" checked?

 

2. Also, are there any 3D graphs in the VI?

 

These two things could definitely cause complications, as per the "Use fast file format" context-help. Regardless, I would like additional context of how you produce this issue in the first place. what steps did you take to create this issue? Can you narrow it down to a simpler reproducing case?

 

If it is specific to your code, can you share the reproducible case with us?

 

Thanks so much for your troubleshooting efforts! They are much appreciated!

Timothy D.
Applications Engineering
National Instruments
0 Kudos
Message 2 of 11
(1,964 Views)

I have "Enable debugging" unchecked, and I don't use any 3D graphs, only XY and intensity graphs. I have an email service request (#7715491) open with NI support which would have a lot of the details if you have access to it, but basically, if I build my project into an .exe with the "Use fast file format" box checked in the build properties, then whenever I try to connect to the front panel of that .exe remotely through its built-in web server (enabled via WebServer.Enabled=True in the application's .ini file and configured through its niwebserver.conf file) then the client pops up a dialog with the error message I gave above. It doesn't matter whether I'm connecting through a web page generated with the Web Publishing Tool, or directly through the "Connect to Remote Panel..." item in the LV "Operate" menu, whether it's running on the local machine or a remote machine. If I uncheck that box before building the .exe, then connecting to the .exe's front panel works correctly.

 

It's not specific to my code; I just tried building a very simple application, and setting that check box makes it fail to connect and pop up the error, whereas clearing that box makes it work. I can share that example if you want, but I'd imagine you can try it with any built .exe by adding that line to the .ini to enable the webserver.

0 Kudos
Message 3 of 11
(1,959 Views)

Hey Aaron,

 

I am going to research this on my end, but you could expedite the process by posting the minimal code to produce the error!


Thanks again!

Timothy D.
Applications Engineering
National Instruments
0 Kudos
Message 4 of 11
(1,933 Views)

Sure, see how this works for you. This includes the built executables with and without "use fast file format" checked.

 

Aaron T.

 

0 Kudos
Message 5 of 11
(1,907 Views)

Hey Aaron,


I'm working on getting this properly escalated on my end. Thanks for reporting this. Just to be clear, the workaround of simply unchecking Fast File Format is sufficient for your goals?

 

Thanks again!

Timothy D.
Applications Engineering
National Instruments
0 Kudos
Message 6 of 11
(1,877 Views)

Yes, that fixes the problem.

0 Kudos
Message 7 of 11
(1,856 Views)

@TimothyDug wrote:

Hey Aaron,


I'm working on getting this properly escalated on my end. Thanks for reporting this. Just to be clear, the workaround of simply unchecking Fast File Format is sufficient for your goals?

 

Thanks again!


CAR# please.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 8 of 11
(1,804 Views)

Ben,

 

I was out of the office for two weeks. We are trying to recreate the issue. I will post here when we have a CAR.

 

Thanks for following up!

Timothy D.
Applications Engineering
National Instruments
0 Kudos
Message 9 of 11
(1,745 Views)

If you need any more information to reproduce it, let me know.

0 Kudos
Message 10 of 11
(1,727 Views)