Showing results for 
Search instead for 
Did you mean: 

"The VI is not executable" on the development machine



I'm a new user to LabVIEW and have begun creating a basic program for a test setup we have, incorporating a Measurement Computing device (USB-1608FS). I've worked out all the kinks and have a few simple functions going so I tried to create an executable to see if it would run on the laptop running the experiment. However, when I try to run the executable on the development machine I get this error:


labview error.PNG


I've looked through the forum archives and have tried mass compiling and playing around with the various Additional Exclusions in the Build Specifications, but to no avail. I suspect it has something to do with the Universal Library since other LabVIEW programs work fine as executables, albeit they are much simpler. If it doesn't work on the same computer that I've developed the VI in LabVIEW, then I doubt it would work on one that doesn't have the development version installed.


I've attached the basic VI for additional clarification. When building the executable, I leave all options as the default except when I tried to change around with the Additional Exclusions. Thank you for any help.


0 Kudos
Message 1 of 12
I have had a similar problem before and for me it turned out to be that I was missing the .NET runtime (my application used it - but I can't see anything in yours that does) so it seems to me that your built VI is unable to find something it needs to run.

The VI you posted is missing some functions - but I guess there isn't anything special in the 'Add Time' SubVI.

LabVIEW Champion, CLA, CLED, CTD
0 Kudos
Message 2 of 12

You are correct, 'Add Time' just does exactly what it says. I added that to the project as an Always Included file just to check, but I ended up getting the same error.

0 Kudos
Message 3 of 12

Yeah - it was only in case you had some .NET call or something unexpected in there.


I absolutely agree with you in that case that it is going to be related to the Universal Library (ULx functions) in your VI.


I would check the Measurement Computing documentation or discuss with their support regarding the problems you are having. I had a very quick look and there are a few things that might be causing your problem - "Configuring your MCC hardware for use with UL for LabVIEW VIs" refers to a CB.CFG file which is used by the library to access the hardware. It might also be that you need to include the library in your EXE if it dynamically calls VIs (for example...)


This may also have the answer: (Universal Library Distribution Guide)



LabVIEW Champion, CLA, CLED, CTD
0 Kudos
Message 4 of 12

I tried adding the CB.CFG file as well as the MccDaq.dll file, as recommended by the source you posted. However, still the same result. I even tried building an application from a Universal Library example, but that gave the same error.


I'm currently engaged in an email exchange with tech support so we'll see where that goes.

0 Kudos
Message 5 of 12

I am having the same problem...

Did you ever figure out a solution?

0 Kudos
Message 6 of 12


A few questions...


What hardware are you using?

What version of LabVIEW?


Did you get the same error message?

0 Kudos
Message 7 of 12

Windows 7, LV 2012 Professional sp1

Measurement computing USB-1208LS


The program works fine, then I build an executable.  If I run the executable (on my development pc), the run arrow is broken and I get the same error, I think the message repeats a lot more though.

0 Kudos
Message 8 of 12

Have used Measurement Computing devices in the past I believe Sam_Sharp is on the right track.


You need to install all of the Measurement Computing software on the target machine

=== Engineer Ambiguously ===
0 Kudos
Message 9 of 12

I attached a pic of the error message.  The error pops up when I click on the broken run arrow.

0 Kudos
Message 10 of 12