Showing results for 
Search instead for 
Did you mean: 

"Internal Software Error occurred in MIG software. Please contact National Instruments Support." Recurring Error



I am having a problem where I get the error "Error -229771 occurred at DAQmx Start" with the information "Internal Software Error occurred in MIG software. Please contact National Instruments Support."


Now, from looking on the forums and in the knowledgebase, I have found that I can resolve this issue by clearing the MAX databse, with the instructions here:


However, this is quite annoying, and happens on an almost daily basis--it happens EVERY time the computer is restarted. I only have one task, so I just delete the data folder and start again, I don't bother reverting to an older copy, but it's still quite cumbersome.


Does anyone have any ideas on how to keep this from happening again?


I am using LabView 2012 (32-bit) on a Windows 7 64-bit machine. I am also using a NI cDAQ-9174, with the first 2 bays populated with a NI 9205 and a NI 9401.




Thanks for any help you can provide,


Mike Witt

0 Kudos
Message 1 of 12

Hi mikewitt


Which version of the DAQmx driver do you have?


Could you add some screen shot of your code and the error?


Has the NI device loader or any other of the National Instruments services ever stopped or presented any problem?



Esteban R.

Message 2 of 12

I have version 9.6.1 of the DAQmx drivers.


I have included screenshots of the code... although only the relevant parts. There is much more to this code, but none of the other code uses the DAQmx palette. All this code does is populates a text box and a boolean indicator, and the other parts of code read from the text box when they need the value.


None of the NI services have stopped, or thrown any errors.


Download All
0 Kudos
Message 3 of 12

Hi mikewitt,


Why don't you try the troubleshooting steps of this link.?


Carmen C.

Message 4 of 12

I have tried that.

0 Kudos
Message 5 of 12

Could you install the latest driver?


Carmen C.

Message 6 of 12

Hey Mike,


I can understand your frustration. We are interested in looking into this further. Would you mind posting a MAX technical report, a copy of the C:\ProgramData\National Instruments\MAX directory when the system is in a bad state, and an export of the Windows event logs? You can also pm me if you'd prefer or if there are size limitations.


Do you encounter any other errors that hint at a database issue? Are you able to expand various drop-downs in MAX? Were there any significant changes that happened on the machine around the time it started to misbehave (software install/update, hardware change, other crash, etc) or has it always been an issue?


Luke W

Product Support Engineer - MAX

0 Kudos
Message 7 of 12

For some reason, the error has stopped occuring. I am no longer able to reproduce this issue. If it occurs again, I will update, but I will not be working on this project after May 1st.


As for the errors that occured, nothing hinted at a database issue, there were absolutely no issues in MAX, I was able to delete and recreate the one task we were using, and in MAX I was able to verify that MAX was seeing the signal. The hint I had was looking up the exact error on the forums and online, and the only solution that worked was deleting and recreating the whole database (restoring a backup did NOT work). The only other thing of note was that if I ran the VI by itself (without ANY projects open), or if I compiled it into an executable, I could run the VI just fine.

0 Kudos
Message 8 of 12

I got same error Error:229771. MIG softare error. I am using Labview 2013. please help me out

0 Kudos
Message 9 of 12

Is it possible that you are not using the latest drivers? I would suggest if updating your drivers does not fix this error to make a new forum thread.

Scott B.
0 Kudos
Message 10 of 12