LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

put a file to webdav windows server with LabVIEW

Tom,

 

as said if file exists I get error -12403, else -12400. With the example I got error -12403 when the directories were requested: Asynchronous Directory Listing.vi

 

Note that all errors coming from the webdav vi's aren't carrying any error information?! Error string stays empty

0 Kudos
Message 11 of 18
(1,154 Views)

Hi,

 

So I looked into the Simple Put VI you are using and this closes the connection to the server after it is called - so having it in a for loop wont work. There is a multiple files option as it is a polymorphic VI - try selecting this and writing you files that way. 

 

I hope this helps,

 

TomS

0 Kudos
Message 12 of 18
(1,141 Views)

Tom,

 

things are going wrong the first time, also the server connection will be closed and can be reconnected again (I even have a 1 sec delay), there is also a connect to server function in this vi, I know it isn't efficient, I was only try to make clear what URI's I tried, but besides inefficiency: It should work. So this is really not the problem. Also the example WebDAv Data Acquisition.lvproj doesn't work, this on is making a connection to the server and when it tries to get the file / directory list, it comes with the same error.

 

Best regards,

0 Kudos
Message 13 of 18
(1,129 Views)

Hi,

 

Would it be possible for you to attach a copy of your VIs so that I can examine your code in more detail?

 

Thanks,

 

Tom 

0 Kudos
Message 14 of 18
(1,123 Views)

Also I've found some information on the error codes you are getting no information for:

 

-124100 - The requested resource is not found - i think your URI is still not right, or as I said before one of the files doesnt exist.

 

-124003 - A request is already pending 

 

I also found this forum post in which someone is trying to acheive a similar thing:

 

http://forums.ni.com/t5/Real-Time-Measurement-and/WebDAV-session-no-error-but-not-connected/td-p/254...

 

I hope this helps,

 

Tom S

0 Kudos
Message 15 of 18
(1,118 Views)

hello Tom,

 

Yest the error was 124100 if the file didn't exist. 124003 is when I add a file name to the URI which exists. But I'm struggling a little bit what request is pending? I'm the only one communicating with the webdav server. The tests I did are with VI's with not much going on. The easy put and get VI's don't need much around it. 

I also used the daq example (see earlier post) this results in the same, when attempting to retrieve directory / file information. Again doing this to a crio system works without any problem. I see three possibilities:

- something is'n right in the webdav  server configuration or folder sharing, here I followed the tutorial from earlier

- there is something with the PC installation here, something with the domain settings 

- I do something wrong in the VI: the webdav URI should be OK, I configured webdav without any user name and password log in, when working with file explorer / webbrowser no log in pop up appears, so this looks OK. 

 

I'm curious if LabVIEW and a windows webdav server works at your side,

 

thanks!

Download All
0 Kudos
Message 16 of 18
(1,089 Views)

Unfortunately, I am unable to setup a WebDAV server on my computer as we are on a protected network, so I cannot actually test your program. 

 

If the example program isn't working, i imagine that it won't be the LabVIEW program, but the server settings. I would try setting a usename and password to the server to see whether that makes a difference.

 

Kind regards,

 

TomS

Applications Engineering

National Instruments UK

0 Kudos
Message 17 of 18
(1,072 Views)

The problem you seem to be having is write priviledge.  What operating system are you running on the real time target.  The knowledge base article says this.

 

Write Access

(ETS, VxWorks) Your target provides write access to all its folders and files.

(NI Linux Real-Time) If you want to edit or create new folders and files on your target, you can do so only in the following directories:

  • /home/webserv
  • /home/lvuser
  • /tmp
0 Kudos
Message 18 of 18
(844 Views)