LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

problems with multiple hr2000+ in external triggering mode

Solved!
Go to solution

I hope someone can halp me about this problem:

I need to acquire the spectra with two hr2000+ and one nirques256 with labview in external triggering mode.

The external triggering mode is performed by another pc and also the pulpse train generator.

So after a trigger I'm going to generate a 100 impulses every 20ms for each device throught a dedicted board.

 

If I work only with spectra per time the things works very well and the system is really stable BUT if I work with two or three spectra per time I have a really strange  problem (maybe for me) with timeout.

 

This timout is caused by the an incorrect number of impulses:

if I work with two device then I need to generate 200 impulses every 20ms but my spectrometers acquire the data every 40ms but I need toacquire every 20ms

if I work with threedevice then I need to generate 300 impulses every 20ms but my spectrometers acquire the data every 60ms but I need toacquire every 20ms

So in this way I loose the syncronization of the three boards.

 

One options could be to use for every device a dedicated pc

I acquire the signal throught usb and maybe the problem is duo to the bus

I think maybe the problem is duo to vi block! maybe I can use only one istance per time when I call the procedure

 

Thanks

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0 Kudos
Message 1 of 3
(1,423 Views)

You don't explain what the instruments are, you don't explain how they communicate with the PC, you don't say very much about what you are trying to do, and you don't post any code.  Would you hire an engineer to help you and require that he wear a blindfold so that he couldn't see the instruments nor could he inspect your programming?

 

Start by taking the LabVIEW code that you use, compressing the folder that contains the main routine and sub-VIs (and, I hope, the LabVIEW Project File that ties them all together), and post the resulting .ZIP file.  Do not bother posting pictures of part of a Block Diagram -- that's not particularly helpful and wastes our time.

 

You speak of a Pulse Train Generator, and of a "dedicated Board" -- what board, in what PC is it located (the one running the LabVIEW code, or the one doing the "external triggering mode ... performed by another PC")?  Does your Triggering Board have multiple outputs so you can trigger multiple devices?  What is the Triggering Board?

 

I hope you see the problem we have answering your question as originally posted.  We are here to help, but few of us have advanced Telepathy (there are a few LabVIEW Champions who I think possess this ability ...).

 

Bob Schor

0 Kudos
Message 2 of 3
(1,397 Views)
Solution
Accepted by Ben

I've just solved the problem: it was a problem with reentrancy

Of default labview use non-reentrant execution

0 Kudos
Message 3 of 3
(1,392 Views)