LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

problem with receiving read from several Eurotherm 3216

Hello!

 

I have seven Eurotherm 3216 PID controllers, connected them as the Eurotherm engineer guide shows. I have set each of them in a Baud Rate of 9600, gave them address ID in a series of 1 to 7. I am using MOXA 1150 as a USB converter for RS232/485, and it was also set with a baud rate of 9600 in the device manager.

victsh_1-1616185191079.png

(It work in any Flow control both in Itools or LabView when I give commands)

victsh_2-1616185256254.png

It works only when I set RS-232 in the device manager. However, in the PIDS, it is set to R485.

and again, it works great together via Itools or giving commands in LabView.

When I try to set this option to RS-485 2W or 4W, they no longer work.

 

A proof that ITools communicate with the PIDS.

victsh_3-1616185469883.png

 

 

 

The Pid controllers work flawlessly with Itools, without issues.

When I try to run it via LabView (I am using 32xx Eurotherm driver), I can only provide commands, such as set temperature to 30 C, 10 C, etc.

However, when I try to receive the current temperature (Address 1 or 32770), I am receiving an error.

Moreover, It happens to any ''read'' commands.

What should I do?

I tried to locate the error with a simple VI script of connection and read the temperature.

I used the Highlight method to track the first error point.

The LabView error panel telling me that there is an error with Utility MODBUS RTU receive message.

What should I do?

 

victsh_0-1616185102478.png

 

Thank for any help!

0 Kudos
Message 1 of 7
(1,715 Views)

Hello,

 

I have a problem with this device about Open file+.vi

I cannot detect what I am doing wrong in this file. Please, any suggestions?

Thanks.

marhgct_0-1641393370563.png

 

0 Kudos
Message 2 of 7
(1,481 Views)

Hi mar,

 


@marhgct wrote:

Please, any suggestions?


As can be read in this error message: file not found!

 

(Hint: "Not a path" is not a valid file path...)

 

Btw we cannot debug images!

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 3 of 7
(1,476 Views)

Sorry,

 

I solved the problem. It was in another file.

 

Thanks for everything anyway.

0 Kudos
Message 4 of 7
(1,450 Views)

How do you solve it please? 

I have same problem.

Thanks.

0 Kudos
Message 5 of 7
(673 Views)

Hi, could you provide us schematic of wiring how did you connect 7 eurotherms via rs232 with moxa 1150? Is it possible to connect multiple eurotherms through one usb port.

0 Kudos
Message 6 of 7
(627 Views)

I had to go through as solve this as well, the driver as provided references

 

C:\Program Files\National Instruments\LabVIEW 2017\instr.lib\Eurotherm 32xx Series\Private\3200 Data.xls

 

This needs to be copied to

 

C:\Program Files\National Instruments\LabVIEW 2017\instr.lib\Eurotherm 32xx Series\

 

et voila - the driver works.

0 Kudos
Message 7 of 7
(261 Views)