LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

numeric timestamp different from time string

Highlighted

I have results files from an instrument logging at 10Hz with a numeric timstamp in column 0 (from labview program which logs the instrument and writes to spreadsheet at %.3f). I have a timing problem exemplified in the attached vi screenshot (input and example results files from it too large to attach)

 

  

If I convert the numeric timestamp in the input (.ec) files to a string or a date time record cluster in labview the time differs (order of seconds) from that when the numeric timestamp is converted to date time display in excel (see highlighted in the excel results file). The numeric timestamp in the output appended array matches that from the input files when directly opened in excel so I do not think its a problem with precision at the read/write from spreadsheet. I assume that this numeric timestamp is also therefore the true time. The problem seems to be with the conversion to a date time string or date time rec cluster in LabView, any ideas why this is (I guess an offset could be added to the datetime numeric before conversion to string or cluster to give the correct values but I would like to know why this is happening. Thanks,
 
Emily
Download All
0 Kudos
Message 1 of 6
(1,098 Views)
Highlighted

example input files

0 Kudos
Message 2 of 6
(1,089 Views)
Highlighted
0 Kudos
Message 3 of 6
(1,085 Views)
Highlighted

Hi ermptr,

 

whyt do you want to show with this "small" Excel worksheet?

The number look quite ok for me…

 

You know LabVIEW displays timestamp according to your OS time zone setting, but uses UTC internally?

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 4 of 6
(1,069 Views)
Highlighted

See highlighted at the bottom of the spreadsheet the string time  (and HH MM from the cluster) differs from the timestamp number. Yes I have set to date string and to date time rec to UTC. Thanks, Emily

0 Kudos
Message 5 of 6
(1,063 Views)
Highlighted

Hi Emily,

 

maybe some trivial Excel rounding errors?

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 6 of 6
(1,060 Views)