LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

networking between laptop and sbRIO 9632 over router

Hi all,

 

For my project I'm trying to control the starter kit 2.0 (sbRIO 9632) remotely from my laptop.

 

I want to connect my laptop wirelessly to a Linksys E2500 router wirelessly and have the robot connected to the same router via ethernet cable.

 

I have a working code for controlling the robot from my laptop if connected by cable.

I also have a working code to transfer data via TCP/IP between 2 devices. I used 2 computers connected to the router and was able to change a control on the server laptop and receive the changing data on the client laptop. This worked when both were connected wirelessly and when one was connected wirelessly and the other by ethernet to the router.

 

However I can't get the robot to respond to any control I send. I deployed the VI on the robot as startup and connect it to the router before turning it on.

 

I'm assuming the IP configuration is wrong somewhere but I can't figure it out.

 

Wireless LAN connection on my laptop:

IPv4 ................ 192.168.1.100

subnet mask .. 255.255.255.0

default gateway 192.168.1.1

 

On the TCP/IP VI I'm using 192.168.1.100 as that worked between the 2 laptops.

I changed the IP setting of the robot to be the same including the subnet mask on MAX and it shows the robot has access to it (pic provided)

 

Any suggestions would be greatly appreciated thanks

 

MortZxD

Download All
Message 1 of 9
(2,795 Views)

You have an IP conflict. Both your laptop and robot are requesting the same IP, leading to a conflict and dropped connection. It probably worked on the laptops because at least one was configured for DHCP. Use the same mask/gateway, but set different IPs. Also make sure DHCP is disabled on the router and/or the IPs you are setting are not in its lease pool. Generally everything after .200 is free for static IP usage, but the specifics are up to your router.

0 Kudos
Message 2 of 9
(2,737 Views)

Do we have to use only 192.168.1.1 or type http://192.168.1.1 ? Cause I am a new user?

 

 

0 Kudos
Message 3 of 9
(2,584 Views)

It really depends on which VIs you're using. Why not try both? Also, start a new thread if you're having a similar problem.

0 Kudos
Message 4 of 9
(2,581 Views)

@stha2232 wrote:

Do we have to use only 192.168.1.1 or type http://192.168.1.1 ? Cause I am a new user?


Define what you mean by "use". Where exactly are you typing this?

0 Kudos
Message 5 of 9
(2,571 Views)

Sorry I didn't notice this when you first posted it.

  • This looks like a LabVIEW-RT project (indeed, you have HostMain and RealTimeMain).  I'm assuming that the RealTimeMain is supposed to be deployed on the sbRIO at IP 192.168.1.100.
  • I'm assuming that the sbRIO has the IP 192.168.1.100.  Since your subnet Mask is 255.255.255.0, the PC you are using to connect to the sbRIO needs to have an IP address of 192.168.1.xxx, where xxx is anything except 100.  The matching 192.168.1 puts it in the same subnet.
  • How you connect the two can vary.  If you use an Ethernet cable (probably a crossover cable, or through a simple switch), there's no additional addressing to worry about.  If you are attempting to connect wirelessly, with your sbRIO "wired" to your wireless router, then the router needs to accept addresses in the 192.168.1.xxx range, and your PC's wireless IP must be in this range.
  • For the next step, you'll want to connect the sbRIO to your PC, either through a cable or through the router.  I'd first verify that you can "see" the sbRIO by going to a Command Prompt and giving the command "ping 192.168.1.100".  You should see a successful connection with four Reply From messages.  If not, then you've got a basic Network problem (bad cable?).
  • So let's say you can "see" your sbRIO.  Open your Project, and click on Starter Kit sbRIO -- with luck, if the sbRIO is on your local network, it should "find" it.  Otherwise, right-click and specify it, using the IP if necessary.
  • Once the Project finds your two Targets (My Computer and sbRIO), drag the code destined for the RT Target (RealTimeMain) into the top level of the sbRIO Target in Project.  Once you have finished with development, you can use Project to Deploy your code to the sbRIO.  Again, it doesn't matter how you connect your PC to the sbRIO -- an ethernet cable, wireless, etc.
  • Finally, when it talks about IP, it means "IP", not "Web address", so http:// is not necessary (and not appropriate).

Hope this is helpful to you.

 

Bob Schor

Message 6 of 9
(2,552 Views)

(Bob, I think these are two different users, positng over a month apart. The two questions are probably unrelated)

Message 7 of 9
(2,549 Views)

@altenbach wrote:

(Bob, I think these are two different users, positng over a month apart. The two questions are probably unrelated)


Oops ...

 

BS

0 Kudos
Message 8 of 9
(2,538 Views)

Just Change the IP address of the robot from static IP to Dynamic IP in Max. It will work

0 Kudos
Message 9 of 9
(1,792 Views)