LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

myRIO not responding after creating an app %28.exe%29

Hello,

I have tried creating a stand-alone real-time application with myRIO as the target using this link:

http://zone.ni.com/reference/en-XX/help/370622J-01/lvrthowto/rt_building_rt_app/

After implementing it and installing the app using MAX, the program is not running at all (takes forever for myRIO to respond)

I removed the created app from the project, but my original project is still not running. How can I fix this?

Thanks for the help! 

 

0 Kudos
Message 1 of 2
(2,602 Views)

You will need to build the application through the project explorer, set the the .rtexe to 'Run as startup', and then deploy it.

 

'How Do I Deploy a Startup Executable to my Real-Time Controller?'

http://digital.ni.com/public.nsf/allkb/B37FA04A1CB84B6C862571A30060EF03

 

If that is still not working, you may want to consider:

 

1. Checking to make sure that you can establish a connection between your project and the myRIO. Right-click on your myRIO target in the project and select 'Connect'

2. Verifying that you can run your code interactively (i.e. run your RT code directly from the host computer)

3. Writing a very simple myRIO application that toggles a user LED. This will allow you to visually see whether or not the application is running.

 

'NI Community: Toggle User LED on cRIO Target'

https://decibel.ni.com/content/docs/DOC-29852

 

~ Q ~

 

 

0 Kudos
Message 2 of 2
(2,515 Views)