LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

myRIO not found

Solved!
Go to solution
Highlighted

@NapDynamite wrote:

I have tried rebooting myRIO but still it never shows up in MAX. 

 


I didn't say reboot it, I said reboot it in 'safe mode' as per the instructions. You could also try connecting to the console UART to see if the myRIO is booting up correctly - as per the manual I linked to.

 

Have you tried the myRIO on another PC? Do you know someone else that has a myRIO and you could try plugging it into their PC / plug theirs into yours?

0 Kudos
Message 11 of 15
(2,130 Views)
Highlighted

Apologies. I meant "rebooted in safe mode". Yes I did that but still MAX shows nothing. Tried migrating entire setup on another PC but still myRIO isn't detectable. I have no clue what is wrong. I cannpt even reinstall software inside myRIO to check what was missing unless MAX detects it either through USB or WIFI.


0 Kudos
Message 12 of 15
(2,104 Views)
Highlighted

The USBLAN adapter is not automatically assigning default IP address 172.22.11.2 to itself. Moreover it's not showing as a discrete LAN connection. 
To use UART console I'd need UART-USBconvertor to shift voltage level and read it on my PC. 


0 Kudos
Message 13 of 15
(2,100 Views)
Highlighted

The USBLAN adapter that ships with myRIO is from Belcara Tecnologies. Maybe there's something wrong with this driver which is not supporting windows 10. Sad thing is I don't have any previous Windows versions running in any of my systems. 


0 Kudos
Message 14 of 15
(2,094 Views)
Highlighted
Solution
Accepted by topic author NapDynamite

So it turned out that my VMware's Virtual network bridge was blocking USBLAN connection somehow. After removing this bridge connection, I got myRIO working like a charm once again. 🙂


0 Kudos
Message 15 of 15
(2,084 Views)