Showing results for 
Search instead for 
Did you mean: 

myRIO not found

Go to solution



I have myRIO 1900 with entire software bundle installed. I have connected it via USB cable but device monitor says "No NI myRIO was found". Niether I can locate it in MAX (remote devices). Tried reinstalling the software on my PC along with drivers but same issue. 




0 Kudos
Message 1 of 15

These are the obvious suggestions, they aren't meant to be patronising - but your myRIO is powered up? Are the LEDs on on the board etc.? Have you tried another USB cable and/or tried it on another PC? Does it show up in Windows Device Manager? Does it show up as an unidentified device, or does it show it with the driver installed?


The more likely problem is that something went wrong during the installation - a list of the software you have installed in MAX might be helpful. Try reinstalling LabVIEW RT, the myRIO toolkit, CompactRIO drivers etc. after you've installed LabVIEW.

0 Kudos
Message 2 of 15

Hi! Are you able to see it connected in Windows Device Manager?

0 Kudos
Message 3 of 15

Answers to your question:


Is myRIO powered up?


Are the LEDS on, on the board? 

Yes. The power LED in ON, status LED goes RED when myRIO is powered up and then goes OFF and WIFI LED is always OFF. (crazy isn't it).

Have you tried another USB cable and/or tried it on another PC?

YES and NO. Will do try it in another PC.

Does it show up in Windows Device Manager?

YES. A USBLAN adapter shows up in Netowrk Devices but not myRIO.

Does it show up as an unidentified device, or does it show it with the driver installed?

No it doesn't. A USBLAN network adapter shows up in device manager. 



I have tried reinstalling the entire National Instruments softwares i.e. LabVIEW, RT, myRIO toolkit, FPGA, Xilinx Tools etc. ( I know most of them are never needed to reinstall but still). 





0 Kudos
Message 4 of 15


0 Kudos
Message 5 of 15

What do the network settings look like for the USBLAN adapter? Here's what it looks like for me (with a 9066, but it's very similar for the myRIO I believe):



Perhaps you have an issue with Windows / IT / Corporate / University Firewall blocking the communications between your computer and the myRIO?


How did you get the LabVIEW / myRIO software? Which version are you using? You might want to try a different version to see if it works? There are download links on this page:


0 Kudos
Message 6 of 15

Well I do see USBLAN under Network Adapters in Device Manager but I don't se this guy as a Local Area Connection in Network and Internet>Network Connections. 

And also I see myRIO as Unspecified under devices and printers. 

I got LabVIEW/myRIO software with the myRIO hardware box. It came with it as DVDs. 



0 Kudos
Message 7 of 15

Previously I was geting everything work like a charm over a Wireless connection. My myRIO was showing in MAX under Remote Devices and configured to use over my personal wifi connection. Then, in order to make it work over USB cable, I reinstalled entire software bundle (LabVIEW, RT, myRIO toolkit) and also DELETED myRIO from MAX. After this myRIO won't talk to me. 


I am running everything on windows 10. It may be the case that my OS isn't recognising USBLAN adapter. Also I see the wireless LED in OFF so it means myRIO is having trouble coonecting to my wifi network. 



0 Kudos
Message 8 of 15

I find it very strange that it isn't enumerating a network in your network adapters page which makes me think there might be something wrong with the software on the myRIO itself.


Have you tried rebooting the myRIO into safe-mode (press and hold reset button for 5 seconds - Does it then show up in MAX?


What version of LabVIEW/drivers came with your myRIO?


There are a couple of articles here about myRIO connectivity issues - they might not apply, but it's worth a look:


Why did you reinstall the entire software bundle to make it work over the USB cable? As part of your troubleshooting?


0 Kudos
Message 9 of 15

I have tried rebooting myRIO but still it never shows up in MAX. 

I am running 2014 (14.0) versions of all software packages (LV, RT, myRIO, FPGA). 
And YES as a part of my troubleshooting I first reinstalled individual modules and then reinstalled entire software bundle just to make things sure. 


Now the only think left to do is to download latest versions of every software module and check. But this behavior is very strange and I hope to get it fixed soon since I'm short of my project deadline. 😞

0 Kudos
Message 10 of 15